Original topic:

S20 WhatsApp call full screen without pop-up notifications

(Topic created: 02-20-2024 09:52 PM)
573 Views
Nicoooo
Constellation
Options
Galaxy S20

Hello everyone,

so I just bought an S20 and the problem I propose is simple.

So if there's one thing I hate about notifications, it's pop-up notifications. That is, because every time I get a notification, it has to appear on the screen, to disturb me, to block part of the videos I'm watching or while I'm watching the matches or something else. Or even worse if my cell phone is in the hand of someone else perhaps to show them a video or something, why do others have to see who writes to me and what they write to me? It's just annoying and intrusive.

Perfect, so I go app by app (scandalous that there isn't an option to remove all pop-up notifications and hello) and disable the pop-up notifications of each app. Perfect.

Well, by doing this I now discover that in this new system, if I deactivate the pop-up notifications on WhatsApp, the calls do not appear in full screen. If the screen is blocked it doesn't even turn on... the phone vibrates, but the screen doesn't turn on and there isn't even a LED (obviously, to use edge lighting, you need active pop-ups... .incredible...).

Why do I ask myself? Why does it only get worse as we go forward? What's the point of forcing people to activate those annoying pop-ups? This was never a problem on my old S9 or S7...notifications appear as an icon in the top bar, then when a phone call arrives, as it should, it shows up in full screen...which It's been happening since cell phones, rightly so. But not now... we have to have pop-ups active to know when they call us... absurd.

 

Please tell me there is a workaround for this because it is scandalous.

Thank you.

Nico

2 Replies
Hatem0
Astronaut
Options
Galaxy S20
Weird, i don't have this problem.
From settings, search for App notification. Play around these settings, and make sure to check "shown as pop up" under notification category
0 Likes
Nicoooo
Constellation
Options
Galaxy S20

Yesterday the support replied to me, saying that there's no solution (in the Italian forum).

Later I called the assistance, and they told me there's no solution: if you have the pop-ups you also have the screen turning on when called, if you have the pop-ups turned off, then you don't have nothing.

I thought this was incredible and stupid, so I started having some tries here and there and found the solution myself, which was pretty wasy (even if I still think they managed to make this extremely complicated for users).

What you have to do is going in Settings, Notifications, App Notifications, Whatsapp and the allow the Pop-ups. At that point, in the same page, select Notification Category and choose in each category if you want to activate or not the "Show as popup" option. In my case, I disabled "Show as popup" in every category except for the last one: "Calls notification", here I allowed the popups.

The trick is that, if you don't allow the popups in "App Notification" in the first place, you will not be shown the "Show as popup" option in the categories. Is a bit tricky.

I still find it incredible that the assistance doesn't know something as simple. I mean...those are the devices they are working with...it's a simple request and they simply can't solve this but they tell you "you can't do that"...incredible...

 
0 Likes