cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Asteroid

S20 not working with Android Auto

Recently purchased a new S20 and I can't get my Android auto to work. When I initially connect usb it will connect up and then the screen on the head unit goes black. If I go to the menu it shows the Android Auto is connected but if I select it again just a black screen. Any one with any ideas?

 

21 REPLIES 21
Highlighted
Cosmic Ray

Re: S20 not working with Android Auto

What kind of car? It works fine with my Kia UVO and Dodge UCONNECT

Reply
Loading...
Highlighted
Asteroid

Re: S20 not working with Android Auto

I have a Sony Xav-ax100 that I installed about 3 years ago has worked fine with the S8.

Reply
Loading...
Highlighted
Asteroid

Re: S20 not working with Android Auto

I'm having the same issue. I had an S8 that worked fine. I plug my 20 in and it works for a few minutes then I get a message saying please reconnect device when stopped and safe, but of course the device is never unplugged. Samsung chat tried blaming my Kenwood Head Unit in the car saying it will need a firmware update...I feel like it would be on samsungs end not the stero on a wired connection using an existing app. 

Reply
Loading...
Highlighted
Asteroid

Re: S20 not working with Android Auto

I'm the same the S8 has worked fine for the last couple of years, I don't even get an error message just a black screen but it still seems like Android auto is  connected. I can't see why it would be a firmware issue if like you it has previously been work on the s8

Reply
Loading...
Highlighted
Constellation

Re: S20 not working with Android Auto

Having the same issue with my Pioneer Nex

Reply
Loading...
Highlighted
Astronaut

Re: S20 not working with Android Auto

I had the same issue.

 

The problem comes from a poor USB cable. If you replace the cable to a quality cable all issues should be resolved

Reply
Loading...
Highlighted
Asteroid

Re: S20 not working with Android Auto

Not necessarily true.  I had a Galaxy S7 Active that was working prior to the January or Febuary revision to Android Auto.  Once the update took place in late febuary, all voice features and call features stopped working.  Music and Map features work, but no voice or phone.  I bought the new S20+ 2 weeks ago, and same issue with same version of Android Auto.  Neither phone works, with any cable on any of my 3 Pioneer NEX models(different models in different vehicles.)  I updated all of them to current firmware, with no fix.  This is a known issue with the latest release of Android Auto.

Reply
Loading...
Highlighted
Constellation

Re: S20 not working with Android Auto

Is the Dex program starting instead? I disabled Dex on my phone and Android Auto started working properly again.

Reply
Loading...
Highlighted
Asteroid

Re: S20 not working with Android Auto

I will give this a shot, but did not have DEX on my Galazy S7 Active, with android auto update from febuary stopped working with call and voice features.  Maps and Music worked, but no voice in navagation either...  My new S20+ purchased first of march has the same issues...  I disabled DEX this evening, and when I get a chance to test in vehicle, I will report back.

Reply
Loading...