Original topic:

S20 plus wifi disconnecting

(Topic created on: 2/1/21 12:01 PM)
userf2GKFTcv6R
Astronaut
Options
Galaxy S20
Android 11 messed my wifi connection up and it constantly disconnects and reconnects.  I've submitted a ticket with no fix since December.  I've received two system updates since and issue is still there.  Have tried all solutions including turning Google location accuracy off.  Setting static ip.  Disabling wifi scanning throttling.  Factory reset phone.  Does it even booted up in safe mode.  This is on 2 phones so it's not the device.  But it doesn't happen on all wifi.  Problem is on AT&T uverse connection.  Have replaced router even though no other device has any issue with connection besides the two s20 plus.  Please quit ignoring this issue and help us get a fix.  
14 Replies
Options
Galaxy S20
Turn off Mobile Data. Check operation on wifi only.
Turn off wifi. Check operation on Mobile Data only.
Turn on both. Check if phone bounces back and forth between the two. If Data is predominant wifi is weak or malfunctioning.
Confirm with known, strong wifi (2.0 Hotspot)
0 Likes
DGM
Sun
Options
Galaxy S20
Have you tried turning off 5g? Should have nothing to do with it, but sometimes 5G is causing weird problems...

settings/connections/mobile networks/network mode/LTE...

If you're on Verizon, you can't turn off 5g like this...

btw, I'm on ATT U verse router with same phone... no problems.

Here's another idea... Go to Smart Home Manager on your phone... if you don't have that ATT app on phone get, it... you can prioritize 2 devices on your network. Try doing that on your phones to see if it helps. I think prioritization periods are only 2 hours, but this may lead to an answer if it works. Good luck.
0 Likes
Options
Galaxy S20
DGM is onto something with priorization. My router with my WISP (wireless internet service provider) does not like any priorization of any kind.
0 Likes
userf2GKFTcv6R
Astronaut
Options
Galaxy S20
I have turned cellular off still same issue. I have Verizon phones. But I will try the smart home app. I have tried disabling 5ghz and only running 2.4ghz in settings though. I will let u know if it works.
0 Likes
Options
Galaxy S20
should have written prioritization rather than my misspelled version
0 Likes
userf2GKFTcv6R
Astronaut
Options
Galaxy S20
where is the settings for prioritization I have the app now and logged in but not finding it.
0 Likes
userf2GKFTcv6R
Astronaut
Options
Galaxy S20
found the setting that didn't help it still disconnects.
0 Likes
JiminyClickit
Constellation
Options
Galaxy S20

Hi All,

So I had been experiencing a similar issue as everyone else.  The WIFI would be connected, I'd be streaming something and then the stream would stop, the WIFI would say it's connected, but then drop it's ability to connect through to the internet.  Turning WIFI off/on would bring the connection back, but this was annoying as it could happen many times in a row through the course of a day.  My other Android devices and partners iPhone do not experience this. - I should note, that this was only on my home WIFI

I had tried all the of the fixes I could find

  • Resetting the Network settings on the device
  • Forgetting and re-adding the WIFI
  • Resetting the device to factory
  • Disabling 5G
  • Disabling location accuracy
  • Disabling google location accuracy
  • Disable WIFI scanning

None of these provided a permanently solution, as the issue would reappear an hour or two later.

Possible Solution:

What I found worked for me was to disable the Randomized MAC Address option for the specific WIFI connection I was connecting to,  I would only do this on your own private home network, and not any public or work connections - as MAC randomization prevents listeners from using MAC addresses to build a history of device activity, thus increasing user privacy. This has been enabled by default since Android 10.0

To do change the setting:

  • Open the WIFI Menu
  • Tap the Cog on the WIFI connection you want to change
  • Expand the Advanced options
  • Under "MAC Address Type" change this to "Phone MAC"
  • Let the settings apply
  • Disable/Enable WIFI and you should be all good

I haven't had my WIFI drop it's connection since.

0 Likes
user7rE3GZUmoF
Astronaut
Options
Galaxy S20

Changing from Mac address type to phone Mac worked thanks heaps mate was literally dropping out non stop it was so frustrating

0 Likes