JUMP TO SOLUTION Solved

Original topic:

Turn off Auto Network preference for WIFI call

(Topic created: 09-11-2020 09:17 PM)
Outdoorsman14
Astronaut
Options
Galaxy S20
Is there a possibility to stop the auto network preference for WIFI calling? Mine keeps trying to switch it to cellular preferred and I have horrible cell coverage at my house and I end up missing phone calls and texts when it gets changed from Wifi preferred.

1 Solution


Accepted Solutions
Solution
user6aKa7JEXiu
Asteroid
Options
Galaxy S20

I may have found a fix to this. I did this about an hour ago on my Note 9 and have not had the notification pop up since. You need to use nova launcher to access a mobile network settings screen that I can't seem to find in the regular settings menu (if anyone knows how to get there without it, please let us know). The easiest way is to assign access to an unused gesture input. Once you get to the menu, you will see an option for wifi calling, which may be under an "advanced" sub menu. Then select "wifi only" and you should be good to go. Here's a link to screenshots of the process:

 

http://imgur.com/gallery/shOl17K

 

YMMV, as I have not fully tested this for a long period of time so I don't know if it provides full functionality. But for me, so far so good with receiving and making calls and texts. 

View solution in context

Post with 2 votes and 1970 views. Shared by Unconcern. Wifi calling preference optimization fix
0 Likes
Reply
34 Replies
SamsungJoJo
Samsung Moderator
Samsung Moderator
Options
Galaxy S20

Hello,

 

I recommend reaching out to your carrier regarding your concerns. Wifi Calling is a carrier-specific feature.

0 Likes
Reply
Outdoorsman14
Astronaut
Options
Galaxy S20
This was something that has gotten more prevalent since my phone was updated. it is a software related issue, not a carrier issue. Unless the carriers have control over some of the software changes? It seems that that would not be something that Samsung would allow... it literally is changing every 30 minutes at my house when I am on WIFI. And it isn't even a notification that I can make silent... which is more frustrating
SamsungRei
Samsung Moderator
Samsung Moderator
Options
Galaxy S20

https://www.samsung.com/us/support/answer/ANS00077652/



Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.



Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply
Mari_K
Samsung Care Ambassador
Options
Galaxy S20

hello @Outdoorsman14 

 

if you go to settings-connections-wifi (actually tap on the word wifi, not the toggle)-tap the 3 dots in top right corner-advanced and then make sure the first option that says "switch to mobile data" is toggled off.

 

Hope this helps!

*if I have helped you, please LIKE this post. If I have helped solve your problem, please mark this as a SOLUTION. Hope you have a great day!
0 Likes
Reply
Outdoorsman14
Astronaut
Options
Galaxy S20
Thanks! I will try it out! I also appreciate you actually reading my issue and responding with a possible solution!
0 Likes
Reply
Mari_K
Samsung Care Ambassador
Options
Galaxy S20

@Outdoorsman14 

 

I hope this actually helps you. I know for me, I keep that option on because even though my home wifi is really fast, it can be unreliable at times and cuts out, so I want the mobile network to kick in when it's acting funny like that. But if you have reliable wifi, you don't need to have that option on.

 

Let me know if it works out for you! 😊

 

 

*if I have helped you, please LIKE this post. If I have helped solve your problem, please mark this as a SOLUTION. Hope you have a great day!
0 Likes
Reply
Outdoorsman14
Astronaut
Options
Galaxy S20
Unfortunately, that didn't work... I was on the phone and I dropped the call 3 times because it kept switching it to Cellular preferred and then I would lose cell service
Mari_K
Samsung Care Ambassador
Options
Galaxy S20

Ok, so you already tried manually setting your preferred WiFi calling method to WiFi in settings-connections-wifi calling-and then under network preference you changed it to WiFi preferred? But it keeps switching back to mobile, and the other option I mentioned didn't work as well... Hmm.. and your WiFi router has its software updated? 

*if I have helped you, please LIKE this post. If I have helped solve your problem, please mark this as a SOLUTION. Hope you have a great day!
0 Likes
Reply
Outdoorsman14
Astronaut
Options
Galaxy S20
Yeah, I believe that is has to do with the location my office is located in the house. It seems the system is very sensitive to dips in WiFi coverage when it comes to phone reception. I have never had any issues with using my data, it is only phone calls and texts. It appears that if I don't have full rings for my WiFi, my phone thinks I will lose coverage. In reality, my cell coverage drops out in my office, but even then I don't even get 4G where I live... It says that I have 4 bars of service right now, but no indicator of the type of coverage which means I believe it is 2G maybe? Even still, I am unable to use anything on my phone unless I am on my WiFi
0 Likes
Reply