JUMP TO SOLUTION Solved

Original topic:

Where is sim card manager?

(Topic created on: 8/15/20 12:09 PM)
userV4StC2j0ZD
Asteroid
Options
Galaxy S20

i have an S20  on snapdragon (only 1 physical sim card). And i can't use eSIM... simply there is no "sim card manager", i know where it should be, but there in none. As well search didn't help.

In internet i found that not only me have such problem.

11 Replies
Solution
SJohnson
Samsung Care Ambassador
Options
Galaxy S20

Currently, esim is disabled in the United States



Please follow all community guidelines before posting


View solution in context

userV4StC2j0ZD
Asteroid
Options
Galaxy S20

I see, but i dont live in USA, more than it i am in Turkey now...

0 Likes
Reply
SJohnson
Samsung Care Ambassador
Options
Galaxy S20

You still wouldn't be able to enable it unfortunately



Please follow all community guidelines before posting


userV4StC2j0ZD
Asteroid
Options
Galaxy S20

Rly unhappy to hear it...

And is there any chance for changing soon?

0 Likes
Reply
SJohnson
Samsung Care Ambassador
Options
Galaxy S20

Not that I know of currently. But I wouldn't expect it anytime soon



Please follow all community guidelines before posting


Samsung_c6noBOo
Asteroid
Options
Galaxy S20

It's never going to get enabled in Samsung USA firmware. No point in waiting... This is a request from Samsung S10 and so on and is in their backlog for years. 

Read somewhere about a person in similar situation and he updated the CSC of the phone. That way you can get the country specific firmware and eventually get the eSim/Sim card manager enabled.

0 Likes
Reply
user2mFQVJGlDQ
Astronaut
Options
Galaxy S20

I had it, my phone is from mexico and I was planning to add the Esim, but i'm currently in the US and the last update diabled the sim card manager option.

0 Likes
Reply
Samsung_Ax9c35W
Astronaut
Options
Galaxy S20
I have the same problem...please, samsung has to enable the esim !!! I'm living in Spain
0 Likes
Reply
pandamon1212
Astronaut
Options
Galaxy S20
be patient
0 Likes
Reply