Original topic:

wifi and hotspot

(Topic created: 06-15-2021 11:00 AM)
DragonSlayr
Asteroid
Options
Galaxy S20

Since some threads are marked a "solved" on these issues, I thought I'd make another.

The s20 Can not ping inside a network without loosing packets.  Turning on hotspot same thing.

The data on this thing is terrible. Even pinging google using 5g data, the pings range wildly from 47m to 180m.

Is there every going to be a fix that works for this?  Have google location off. Wireless scanning turned off. Facebook turned off.  It's an awfully expensive phone to be having this issue!!

Any ideas at all would be good. Or even a voice of reality is ok, just say there can not or will not fix the issue..

6 Replies
BrownBrown
Astronaut
Options
Galaxy S20
Thanks
0 Likes
Grendeth9495
Cosmic Ray
Options
Galaxy S20
Well the latency is due to it being a cellular device, there will always be high latency on mobile networks. Also, of course, ping uses data. It's still a packet of data. And if you're on wifi and dropping packets, I assume you've tried other devices and verified they do not drop any packets? I do not believe it's your device as I use my S20FE in dex and use termux as a bash emulator. Never had dropped ping. Please provide more data and I can try to assist in troubleshooting! Thanks
0 Likes
DragonSlayr
Asteroid
Options
Galaxy S20

s20 Ultra

I do not have another phone handy, so I hooked my laptop to the same access point my phone is hooked to.

I pinged a local machine continously and ranged from 2-6ms with one jumping to 17ms.

Now the phone:

9% packet loss

pings from 3ms to 315ms

At home, I tried a new access point that would do 5g, same issue..

Have reset the phone, and still have the issue. Am open to any and all suggestions.

0 Likes
DragonSlayr
Asteroid
Options
Galaxy S20

I hooked up a third access point, repeated the test. The laptop now stays at about 1-4ms

The phone, ranges from 2ms up to 336 ms, but stay's below 12ms most of the times with a wide swing now and then. But NO PACKET LOSS. This is a huge improvement, though I'm disappointed still in the bad implementation of wireless on the phone.

At work old Ubiquity AP N - Terrible

At home old tp-link AP N - Terrible

At home new tp-link 5ghz AP AC - Terrible

At work new 450 tp-link N - Much better! (Going to try taking this one home)

To anyone that reads this, I also reset the sim card right before I hooked up this third AP, though it seemed to make no difference. It would seem to date, these phones are very picky of the wireless they connect to. I will find this post and update if something new develops.

And am still open to suggestion of how to fix the phone.

0 Likes
Blue7
Sun
Options
Galaxy S20

have you contacted the carrier for hotspot issue?

i would submit an error report on members app for wi-fi issue.. have you rebooted your wi-fi router?

0 Likes
DragonSlayr
Asteroid
Options
Galaxy S20

I did contact Verizon, but got knocked of in the middle of the session while tier 2 was checking it all out. Then their site said they were experiencing issues, please try again later.

I'll try the members thing as well..  Though the third access point is working decently now.  Problem is ANYWHERE BUT THE HOUSE.

 

0 Likes