Original topic:

FYI: s21 Ultra is not compatible with Google Fi wifi calling

(Topic created: 06-23-2021 04:18 PM)
mikeisbest
Astronaut
Options
Galaxy S21
I just has a support session with Google Fi, and they stated that wifi calling is not available on the s21 Ultra yet. I'm pretty annoyed by that. 

image


image

Googles own website gave me the impression that all the features would be available on this phone. 
0 Likes
5 Replies
MrJell_Lee
Nebula
Options
Galaxy S21

WiFi Calling is available in the ultra. Go to  settings > Connectivity > WiFi Calling.

This is a feature enabled by your carrier so if you don't see it then talk to them to have it enabled (depending on the carrier this is a paid service) then when you click on the WiFi Calling (not the toggle) it should give you the option of choosing preference of cell or wifi when both are available.

No need to use Google Fi in my opinion

Hope this was what you needed.

0 Likes
mikeisbest
Astronaut
Options
Galaxy S21
I think you misunderstood, Google Fi is my carrier. They know it's a problem, after doing some digging it seems Verizon has similar issues with this phone. Whatever API Samsung is using doesn't seem to work with existing methods some carriers use to activate WiFi calling.
0 Likes
userXcVu7ErfIs
Constellation
Options
Galaxy S21

After much experimentation, I finally got WiFi calling working on my Samsung Galaxy S21 with Verizon.  

I'm still not 100% sure how I did it, but here's what I think helped.  Hope it works for you with Google Fi.   I know Google Fi has an option for Wifi calling right in the Google Fi app.  Make sure that's toggled "on".

Anyway, first, Verizon had to fix my account (Wifi calling wasn't enabled for my account on their network) but even after they corrected this, the actual switch for Wifi calling still wasn't appearing on my Samsung S21.

I tried many things, such as clearing the phone cache, performing a network reset, and VZW even sent me a new 5G SIM card, but none of those seemed to help.

What I THINK helped was that I downloaded "Carrier Services" from Google Play (I saw that recommendation on another message board) and then I enabled all its permissions (not sure if that's necessary but I did so anyway). But then there was still no option to enable Wifi calling.

Then the next day, I tried swapping SIM cards with a work cell phone (a Verizon iPhone 8); that line definitely has Wifi calling enabled, I've been using it for the past year on that phone. BUT the Samsung S21 still didn't give me the option to turn on Wifi calling using that work SIM.

So then, after I re-inserted my own personal Verizon SIM, somehow, the Wifi calling option appeared in the Android settings! So I switched it on. The Wifi calling option also appeared in the "Phone" app, which I also turned on.

In your case, after installing Carrier Services and enabling all its permissions, try removing and then re-inserting your SIM card?  And maybe restart your phone?  Good luck.

0 Likes
useroI6ZmnyLIP
Astronaut
Options
Galaxy S21

Whenever I head to the   site on my phone the user interface does not render properly. I have the Samsung S21 and would like to know how I can resolve this. Would you mind telling me whether the problem lies with the website or with my screen resolution?

0 Likes
userRr3oKaZHqN
Astronaut
Options
Galaxy S21

I got wifi calling working on my plain s21 by installing the google phone app and making it default over the Samsung app

0 Likes