Original topic:

My Samsung S21 Ultra 5g keeps telling me to connect to a network when I have service?

(Topic created: 09-08-2021 06:04 PM)
Sandraaa
Astronaut
Options
Galaxy S21

It keeps telling me to connect to a network when I have service.Does anyone know how to fix this ??

4 Replies
SamsungKnight1
Asteroid
Options
Galaxy S21
Try resetting network settings.
Sbrown88
Asteroid
Options
Galaxy S21
Sometimes my S8+ does this. Im with T-mobile. So far, switching to airplane mode and back seems to do the trick for me. It happens mostly when I leave wifi to start running off the network.
0 Likes
usernNxxfNDArJ
Cosmic Ray
Options
Galaxy S21

I have Tmobile and the old permeant fix for this issue is to set APN protocol to IPv4 or IPv4/IPv6 from the default IPv6.

Here are the Tmobile defaults. https://www.t-mobile.com/support/devices/android/samsung-galaxy-s10/network-apn-and-volte-samsung-ga... You typically cannot change the default APN settings, but you can create a new one with identical settings except for APN protocol. Different providers will have different, but comparable settings.

I first found this tweak years ago and it is still a must even with the S21.

0 Likes
userCDOgSH5OzG
Cosmic Ray
Options
Galaxy S21

What model, carrier and software build do you have?

Software build: (settings > about phone > software information - last 4 digits of SW build number)

0 Likes