JUMP TO SOLUTION Solved

Original topic:

Security policy denies use of camera

(Topic created: 12-18-2021 11:30 AM)
tl5589
Constellation
Options
Galaxy S21

I just signed into the community board and blog to find the answer after an extensive Google search.  I have sensors off, cleared the camera cache and data, reset the phone to factory settings.  All the same not working.  Samsung Galaxy S21+ 

Help is much appreciated!!!

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
user365170tdJ15
Honored Contributor
Options
Galaxy S21
Can you be more specific.

I'll take a wild guess. You're using your phone in dual use, one for work. That's why you see the "deny"?

But it's a guess, because you didn't tell us the circumstances

View solution in context

4 Replies
Solution
user365170tdJ15
Honored Contributor
Options
Galaxy S21
Can you be more specific.

I'll take a wild guess. You're using your phone in dual use, one for work. That's why you see the "deny"?

But it's a guess, because you didn't tell us the circumstances
tl5589
Constellation
Options
Galaxy S21

I never thought of that as I have a work account and personal account intertwined on the phone.  Possibly during an update, some sign-in, etc. was not allowed to reset correctly.  I went ahead and did a factory reset as it seemed I had tried everything.  Thanks to those that responded.  I had never tried the community board for this type of feedback and problem-solving.  Very helpful....Thanks.

Chessplayr
Comet
Options
Galaxy S21
You have the sensors off. If your sensors off it will display that message (because your camera is a sensor).
0 Likes
Reply
71HeavyChevy
Asteroid
Options
Galaxy S21
I Found solution after weeks of searching options other than a factory reset. Safety mode will not work if it's not a 3rd party app.

Symptoms that should be accompanied with this problem will also be present. That should include sensors like Screen Rotation, Gravity, Accelerometer, light etc . and of course the Camera. However the Proximity sensor and GPS funtions do work.

That should tell you that it's a setting in the phones UI. You may not have even activated this setting however mine tripped when I had the last software security update.

The Solution that I found. Had to be found by activating Developer Mode. DO this by pressing Build Number 7x under the Settings Menu.

Slide town the top menu, then Settings, About Phone, Software Information then listed in this menu is Build Number, tap that 7x (while tapping it will countdown remaing taps until your "X many steps from being a developer. ") Once activated back out of menu and now listed is Devolper Options at bottom of Settings menu.

Select then scroll down to Quick Settings Developer Tiles, then in this menu scoll down until the Sensors on/off toggle option is listed. Slide the slider switch to on position. Exit out developer mode to main screen and drop the top menu down by sliding finger from top of the screen down. There should now be a icon for switching sensors on/off. If it's lit up before touching it, then that is your problem. If the icon is not there check for it in the icon selection menu, you may have to add it manually if your active window is full. You may have to remove/trade one from the active window. You can switch it back when finished.

When lit it has actively turned off your sensor pack. Screen rotation should now work along with the camera. Now knowing this you can go back to developer setting and switch this option off if you like. Galaxy A51 android 11.