JUMP TO SOLUTION Solved

Original topic:

Smart Lock Trusted Places Doesn't Work

(Topic created: 05-20-2021 04:28 AM)
Rsnic
Galaxy
Options
Galaxy S21

Hi,

I just recently got a Galaxy S21+; it really is an excellent phone and am quite happy with it.

There is one area that doesn't seem to work.  I have set up Smart Lock to stay unlocked in two circumstances:

  • When connected to my car (Trusted Device)
  • When at Home (Trusted Place)

The Trusted Device feature works fine; however, I can not get the Trusted Place to work.  I have it set use my home address.  When I click on it, all it does is bring up a dialog box at the bottom that says "turn off this location" -- so it seems like I have input it correctly, BUT it does not work.  My phone will lock in my home

 

HELP!

 

Thank you very much

Al
11 Replies
GeorgeBrager209
Product Expert
Options
Galaxy S21

There are two possible tricks to getting the Smart Location to work correctly.

So here's the trick:

  1. Open up the Google Maps app on your phone.
  2. Tap your profile picture in the app's upper-right corner, then select "Settings" followed by "Edit home or work."
  3. Tap the three-dot icon next to the line labeled "Home," "Work," or whatever location is giving you trouble, and then select the "Edit" option ("Edit home," "Edit work," etc.) from the menu that comes up.
  4. On the map that appears next, use your finger to drag the pin representing your location ever so slightly — enough that the address at the top of the screen changes (even if it changes to something that's no longer the exact correct address). Tap the Save button at the bottom of the screen.
  5. Repeat steps 3 and 4, but this time, drag the pin back to your location's correct address. Be sure to tap the Save button again when you're done.

 

The second trick is .

There's not much left to do here: Just tap the notification shown above, and you should be taken into the Trusted Places section of your Android Smart Lock settings. There, your phone should prompt you to use the "new" address as your Trusted Place location. And all you've gotta do is tap "Yes."

If for some reason you didn't get that notification — or maybe you dismissed it inadvertently — just head into your system settings, search for Smart Lock, then head into that section and tap the "Trusted Places" line. (You'll probably have to enter your PIN, pattern, or password first as a security measure.) Tap the line labeled "Trusted Places," then tap the line representing the location you just adjusted and look for the "Turn on this location" prompt at the bottom of the screen.

Tap that, and you should be back in business — with your Smart Lock Trusted Places feature working properly again.

 

Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.

Rsnic
Galaxy
Options
Galaxy S21
@GeorgeBrager209

I tried your recommendations -- both of them, many times & still can't get Trusted Places to work

Any other thoughts?
Al
Dakota95
Asteroid
Options
Galaxy S21
Mine hasn't been working either 😕. Just received a update still doesn't work..
Solution
Options
Galaxy S21
I would suggest using a Bixby routine instead - if home, unlock phone. I could never get Smart Lock to work consistently.
Rsnic
Galaxy
Options
Galaxy S21
Thank you! That seems to be working
Al
0 Likes
Reply
Members_vDzR61z
Constellation
Options
Galaxy S21

What is the Bixby routine?

0 Likes
Reply
Rsnic
Galaxy
Options
Galaxy S21
Hi,

There is a provided Bixby routine called "At Home".

I just edited the THEN tasks, by:
* Deleting those included
* Adding:
-- Connect to WiFi
-- Keep Phone Unlocked
* Saved with same name

That's it
Al
Rsnic
Galaxy
Options
Galaxy S21
I modified provided At Home routine's THEN functions by:
* Deleting those included
* Adding:
-- Connect to WiFi
-- Keep Phone Unlocked
* Saved
Al
0 Likes
Reply
crundle
Cosmic Ray
Options
Galaxy S21
Smart lock doesn't work on my s10 for trusted places either. Have also tried all suggested fixes to no avail. This and other issues started as soon as my phone updated to Android 11 UI 3.1
0 Likes
Reply