Original topic:

Unable to get 1440p@60Hz on monitor while using DeX with new USB-C hubs via HDMI

(Topic created: 01-28-2024 01:44 PM)
833 Views
ShortCappy
Constellation
Options
Galaxy S21

Since May 2021, I've been using DeX with the Samsung S21+ phone and the Baseus Metal Gleam Series 6-in-1 USB-C hub.  I started using an LG 27GP850-B (1440p/2K) monitor since December 2021 after the Multistar app provided higher resolutions beyond 1080p.  Along with some other upgrades (mechanical RGB keyboard, a 100W PD cable and a HDMI 2.1 cable), DeX was amazing to use.  Unfortunately in January 2024, the USB ports in the 6-in-1 hub would no longer be recognized by the S21+ phone, which means I can't use the mouse and keyboard.

I've sought a variety of new USB-C hubs to use:

- Anker 552

- Anker 565 (see below)

- Baseus Metal Gleam Series 8-in-1 (which is nearly the same as the Baseus MGS 6-in-1)

- Baseus Metal Gleam Series II 10-in-1

- fairikabe USB-C Docking Station Dual Monitor 10-in-1

- GiGimundo GGPW-8P

- GuliKit 7-in-1 Docking Station (a SNES-like hub with the same ports as the 6-in-1)

- Orico LED Light 6-in-1

- Satechi Typc-C Multi-Port Adapter 4k with Ethernet V2

- Ugreen Revodok Pro 109 (9-in-1)


The problem starts when using any of the new hubs for the first time with a docked S21+ with Android 14/One UI 6. After plugging the 100W PD and HDMI 2.1 cables to any new hub and docked the phone to it, movements on the phone screen feel sluggish and mirrors it to the 1440p monitor by forcing an output to 4K @ 30Hz, a resolution and refresh rate that I never used.  While launching DeX is possible with any of the new hubs, the monitor still outputs at 4K @ 30Hz, regardless of what resolution I apply in the DeX settings.  Using DeX with a 30Hz refresh rate becomes unbearable to use.  If I exit DeX, turn off the higher resolutions setting within the Multistar app and restart DeX, the monitor screen will black out for a second to output at 1080p @ 60Hz.  I tried using an old HDMI 1.2 cable and get the same result across all 5 new hubs.

The only exception is the Anker 565, which also comes with a DisplayPort.  Using a DP cable from this hub to the monitor successfully outputs a 1440p @ 60Hz resolution/refresh rate and I no longer get sluggish movements on the phone screen when docked.  However, the first order and the replacement of this model were not kept around for an unrelated issue.

Every time I go back to the old Baseus 6-in-1 hub, I can still get the 1440p @ 72Hz resolution/refresh rate on the monitor.

MGS6in1 - 1440p@72Hz on monitor - 2560x1440 on DeX.jpgMGS10in1 - 4K@30Hz on monitor - 3840x2160 on DeX.jpgMGS10in1 - 4K@30Hz on monitor - 2560x1440 on DeX.jpg

FEB 4, 2024 EDIT: Added Orico and Anker USB-C hubs, provided more info and came to the conclusion that DeX fails to output a 1440p resolution via HDMI with Android 14/One UI 6.

FEB 9, 2024 EDIT: Added GiGimundo USB-C hub.

FEB 28, 2024 EDIT: Added Ugreen Revodok Pro 109 USB-C hub.

MAR 10, 2024 EDIT: Added Anker 552, fairikabe and Satechi USB-C hubs.

2 Replies
userra
Comet
Options
Galaxy S21
i used a Google chromecast on my a14 connected to my projector and had no lag. i tried display ports with no avail. this even connected to my benQ monitor with no lag. i bought 2 hubs and again nothing worked but the chromecast
0 Likes
userrqGK5ee0p2
Constellation
Options
Galaxy S21

i have the samme issue where i get 4k/30 and mouse and overall lag.  its unbearbale. i think its my adapter but i dont go through more adapters and returning them  I got two and no luck.