Original topic:

Workaround for WiFi Calling Keeps Turning Off

(Topic created on: 3/28/21 11:00 AM)
Members_Mv7x4xu
Constellation
Options
Galaxy S21

I am also having issues with my new S21. Poor signal reception and WiFi calling turning off before I can make a call. I turn it on and close settings and open settings again to check and WiFi calling switched itself Off. My signal on my old phones was always acceptable with at least two bars and a solid 3G for data. Not anymore with my new S21. I have no signal most of the time at home and when I do I only have one bar and sometimes still no data. I am virtually without a phone at home. I cannot reliably make and receive calls or send and receive text messages in a timely fashion. Text messages would send and receive during the few short times the phone actually connects to the cellular network. I did notice I could make video calls in the messages app while on WiFi.

I just stumbled on this as a workaround for WiFi calling constantly turning off. I set Airplane Mode to On. Then I turn WiFi back On leaving Airplane Mode On as well. And finally I turn WiFi calling On. I can now use my phone at home reliably for calls and texts. When I turn Airplane Mode Off my WiFi calling also switches Off again. But re-enabling Airplane Mode, turning WiFi back on and turning WiFi calling back on works. It's not ideal but at least for those who do not have cellular reception at home this works.

One thing you need to remember is to turn Airplane Mode Off again when leaving home. It's a pain but at least it works. Also, it appears you must perform this workaround in the order listed. 1) Turn Airplane Mode On. 2) Turn WiFi On. 3) Turn WiFi Calling On.

Hope this helps those who are in the same situation as I am with little or no cellular signal at home using the new Samsung Galaxy S21 5G smart phone.

3 Replies
RFtech53
Cosmic Ray
Options
Galaxy S21
If any Samsung Moderator is reading this ... pass this update along to your engineering team.

Ever since I installed a cell phone amplifier at my house, and have gone from "no service" to 2-4 bars ... my WiFi Calling button has not turned itself off.

So apparently there is something in your code that links the two which needs to be rewritten. When I kept having "no service" messages, WiFi Calling would not stay on. Or, it wouldn't even turn on. Or, the GUI wouldn't even show the ability to turn it on as seen in my photo.

And while I'm at it, you KNOW the S21 has issues with signal level and WiFi calling. Why don't you do the stand up thing and let people know it has these issues and that, be assured, you're working on fixes? $1100 phone that people can't use at home after they traded in older Samsung models that worked fine ... ISN'T ACCEPTABLE for a huge Japanese company ... or any company.

Screenshot_20210326-143323_Settings.jpg

0 Likes
bill-e
Samsung Care Ambassador
Options
Galaxy S21

@RFtech53 

You should cut and past this in a error report via Samsung Members.

When you were having issues, you did turn off "Switch to Mobile Networks" under the Advanced WiFi settings right...I've always thought that might be related.

I actually lost my Verizon Network Extender for almost 2 weeks because of a DHCP issue with my fiber router and used WiFi calling from Verizon that whole time without issue.

And Samsung is a South Korean company, not Japanese ;)

Glad you're resolved your issue even if it wasn't the way you had hoped because if you're like many of us working from home, you kinda need your phone.

 

** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy S21 Ultra 512g(VZW), Galaxy Book (original, VZW), Tab S4, Galaxy Watch3 (VZW)
0 Likes
RFtech53
Cosmic Ray
Options
Galaxy S21

Bill-e

Yep I tried that. And thanks for the parent company correction. My bad ... as they say.

Yeah, it upsets me off that I had to spend another $500 to fix a new $1100 phone ... not to mention the work involved in putting it all up. But at least I can use the phone now.

0 Likes