Original topic:

Modes & Routines Do Not Turn Off Grayscale

(Topic created: 03-09-2023 10:58 AM)
ThinkingNebraska
Asteroid
Options
Galaxy S22
Hi! 

I recently got this S22 Ultra (I broke my other one and got a replacement) and have issues with slee mode and routine not turning off grayscale when they stop running. I am running the latest software update. I did have the wake up time routine running and this would turn off grayscale. However, when wake up time would stop running it would turn grayscale back on. I cannot turn grayscale off from the color adjustment menu. When I go there it shows that it is off. Restarting the phone is the only way to correct the problem. Any suggestions on what could be causing this?
12 Replies
PrimePixel
Comet
Options
Galaxy S22
Modes and Routines is quite bugged recently, so I think this is one of those bugs. I have a bug on mine too where the lock screen wallpaper would permanently change it after I use a certain mode with a certain wallpaper on it after a while.
Options
Galaxy S22
Are you turning on sleep mode right now (i.e. having bed icon in the status bar)?

I have been using sleep mode on S22U but I don't have this grayscale issue.
ThinkingNebraska
Asteroid
Options
Galaxy S22
I have been messing around with today, so yes, I have been turning it on manually.
0 Likes
Conditioned
Astronaut
Options
Galaxy S22
ÿou should have stayed clear of devices . you should maybe invest in a flip phone.
0 Likes
Options
Galaxy S22
I think I could reproduce what you have experienced with grayscale. The problem seems to be because of turning sleep mode before the schedule time.

I guess Modes and Rountines priorize conditions/settings of the phone first and their commands come second. I tried this with a simple extra dim routine. I set a routine to turn on extra dim from 5:00pm to 5:01pm so extra dim should be turned off after 5:01pm. However, I manually turned it on at 4:59pm. After 5:01pm, the extra dim was not turned off.

I guess it thought that users want to keep the extra dim on since it was on before the routine so it skipped their command to turn it off.

Same concept could happen with sleep mode. When turning the mode on before time, it remembers the grayscale as the "preferred" settings by users (top-priority). Therefore, when the sleep mode ends, it still keep grayscale on.
ThinkingNebraska
Asteroid
Options
Galaxy S22
That makes sense. I will keep this in mind. Currently, my sleep mode is set to start when my galaxy watch senses it. So, it doesn't start until I am actually asleep. I noticed this morning that sleep mode did not reverse grayscale when it sensed I was awake. Not sure what's going on there.
0 Likes
ThinkingNebraska
Asteroid
Options
Galaxy S22
I think I may found a work around. I made a new routine that starts manually that only turns grayscale off. I turned on sleep mode and then turned it off. Grayscale did not turn off. But it did when I started my manual routine. Not the greatest solution but it works!
MarvinX
Comet
Options
Galaxy S22
With the latest update mine stops working periodically (I have automation set up to read aloud incoming notification from messages) I have to toggle the routine switch on and off sometimes or reboot device.. hope they added this issue soon.
clearimage
Astronaut
Options
Galaxy S22
When using the Sleep Mode in modes and routines, grayscale will not turn off without restarting the phone. I have my phone set-up to exit sleep mode at 6 AM. Everything reverts back to pre sleep mode settings, except for the screen color. I have to restart my phone every morning to exit grayscale. It's terrible to pay do much for a phone, and not be able to take advantage of all it's functions. I have contacted Customer Support several times regarding this issue. No solution at all. I hope Samsung works the bugs out of Modes and Routines soon.