Original topic:

Auto Optimization Issues

(Topic created: 04-13-2024 04:56 AM)
321 Views
AskaLangly
Asteroid
Options
Galaxy S23
Hello. 
I run Spotify in the background while asleep for white noise purpose. 
At around 03:30, auto optimization kicks in, killing Spotify in the process, which causes me to wake up every morning.
I have set Spotify's battery restrictions to Unrestricted and excluded it from memory cleaning.
There is currently no way to disable the device optimization.
I cannot sleep without white noise.
Please allow us to disable this optimization feature!
0 Likes
4 Replies
ButtaBean_420
Black Hole
Options
Galaxy S23
Settings > Device Care > Auto Optimization > Toggle off both Restart When Needed and Restart on Schedule or you can toggle off Restart When Needed and set the Restart o n Schedule to a time during the day when it is a good time for you
terminator9
Comet
Options
Galaxy S23
i use my alexa for white noise to be honest... i pass out in 10 min. but buttabean above has the fix you want
0 Likes
Popsicle20
Red Giant
Options
Galaxy S23
I used to have this problem when I had SiriusXM. Try this and see if it helps.

Long press on the app's icon and go into settings. Go down the page and tap "Battery ". Make sure that "Unrestricted" is selected.

Now go to Settings > Device Care > Battery. Tap Background usage limits. Tap "Never auto sleeping apps". Tap the plus sign at the top of the screen and add Spotify to the list.

This should keep OneUI from repeatedly trying to put Spotify to sleep.
1713033719892.jpg1713033719937.jpg1713034166335.jpg1713034206884.jpg
AskaLangly
Asteroid
Options
Galaxy S23
Seems that Spotify continued to play while the cleaning occurred this morning. I didn't touch any settings. Hmm... strange.
Still, I'm surprised there is no setting for the cleaning, like weekly.Screenshot_20240416_061909_Device care_1000025203_1713262749.pngScreenshot_20240416_062113_Device care_1000025205_1713262873.png
0 Likes