JUMP TO SOLUTION Solved

Original topic:

How to permanently disable DND when using Google maps

(Topic created: 03-28-2023 04:03 PM)
11171 Views
userh2nK2zUMz7
Cosmic Ray
Options
Galaxy S23
How do you permanently disable DND when using Google maps in drive mode? Everything online that I've searched for doesn't seem to work. 
11 Replies
Rydah
Samsung Care Ambassador
Options
Galaxy S23

Hey there @userh2nK2zUMz7, I hope you're doing well.
Have you taken a look into Modes & Routines? Here, you can configure your phone to automatically disable Do Not Disturb whenever the Google Maps app is open.

- Modes & Routines can be found in: Settings>Mode & Routines>Routines> Follow this setup:

- Tap the "+" button>Under "If", Press the "+" and select "App Opened">Maps>Done
- Under "Then", Press the "+" and select: Notifications>Do not disturb>Off>Done. You can now choose if you'd like this action to automatically reverse (enabling DND) once Maps is closed.
Lastly, press the Save button, add a routine name and select done.

Please see the attached screenshot for reference.

Screenshot_20230328_154647_Modes and Routines_1000006471_1680043608.png

 

 

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
0 Likes
Reply
userh2nK2zUMz7
Cosmic Ray
Options
Galaxy S23
Just tired it. The DND still turned on
0 Likes
Reply
Rydah
Samsung Care Ambassador
Options
Galaxy S23
That's very odd. I just tested this exact scenario with the configuration above and it worked flawlessly. Entering the Maps app disabled DND and leaving the Maps app re-enabled DND.

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
0 Likes
Reply
userh2nK2zUMz7
Cosmic Ray
Options
Galaxy S23
Yeah, I dunno. I just tried it again. Deleted the routine and created a new one. It still turned back on.
0 Likes
Reply
Rydah
Samsung Care Ambassador
Options
Galaxy S23
When you say it turned back on, do you mean when you left the Maps app it turned back on? Or DND was off and opening the Maps app turned it back on? Do you get the same results when not connected to a car?

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
0 Likes
Reply
userh2nK2zUMz7
Cosmic Ray
Options
Galaxy S23
DND was off. When I turned on maps DND turned on with the routine created and saved. Yes, same results not connected to a car
0 Likes
Reply
userZNnTdcqwZP
Supernova
Options
Galaxy S23
This is strange because when I use Google maps in driving mode, it is not turning on DND by default. Do you set driving modes in Modes and Routines?

Also, go to Settings >> Safety and emergency >> Silence notification while driving >> check if this is turned on

This might not be relevant but give it a try. Go to Settings >> Apps >> tap 3 dots >> Special access >> Do not disturb permission >> turn off Google and/or Google services framework
0 Likes
Reply
userh2nK2zUMz7
Cosmic Ray
Options
Galaxy S23


All of this has been strange. I have not set the driving mode.

Safety and emergency-it is turned off.

Special access-doesnt allow me to turn off Google. It's grayed out. Framework is turned off
0 Likes
Reply
Solution
userZNnTdcqwZP
Supernova
Options
Galaxy S23
In Google maps, go to Settings >> Navigation settings >> Google assistant settings >> turn off driving mode