Original topic:

S23+ 6.1 update - broken type C port (no charge, moisture error, no connection to PC) and wireless fast charge are not working anymore

(Topic created: 06-13-2024 09:38 AM)
Galaxy S23

Hi all, 

SM-S9160, TW market - S9160ZHS3CXE3 current firmware build

S9160ZHU2CXCF - or even S9160ZHS2CXD1 caused such issue

please help me with my issue - will be appreciated for any advice how to resolve this

1) type C port not working
- PC not recognize as device - I see in device manager error
- most time when I tried to connect to PC - I receive moisture error
- sometimes - phone starting to reconnect several times and start charging - and then stopped with moisture error
- sometimes - charge starting very slow

2) wireless fast charge not working anymore - only slow charge

I used AccuBattery app to see charge power - and it's very low

What I tried to do
- USBSettings app - cleaned cache and data
- cleaned cache after firmware update
- via *#9900# - reset batterystats

- tried to enable\disable battery protection, fast charge settings
- tried different cables\power adapters
- tried to talk with official samsung service - they said that they can try to change type c port but they cannot guarantee that issue will be resolved - that's fine, but how it's related to wireless fast charge issue?

- live chat support usefull - they just advice to go to service, but this is firware problem only - phone didn't touch water at all and clean

I used my phone for 6 month, everything works well, I faced with this issue exactly after firmware update. 

For I think may help - to revert to S9160ZHS2BXAF firmware, but without connection to PC it's even hard to may a backup of 300+ Gb of data

or sit and wait for firmware update

Change type C port or whole chip seems won't solve this issue, maybe togerher with wireless charge chip - will do, but it's more expensive and phone will be not original and opened


4 Replies
Legendary Samsung Care Ambassador
Galaxy S23

@SKravch Unfortunately you have landed in the user to user discussion group for Samsung US products. To find the group for your geographical area, visit https://www.samsung.com/us/common/visitlocationsite/  

Galaxy S23

thank you for your reply, 

it's hard to understand to me where I should put my question

I tried with translator to find a place in TW samsung site - but seems similar forum doesn't exist there. If you can send me a link for concrete TW forum - will be appreciated.

here in Europe market it's possible to purchase US or Asia versions too

hopefully similar issue won't touch another samsung customers

From current my device behaviour:
- after update from google play Android Auto app - I don't see moisture error anymore (maybe such issue caused by moisture detection sensor?)
- via type C phone can slow charge from adapter and PC
- wireless charge still very slow

I'm waiting for next firmware update for now
if it won't help only 2 ways I see for now
- pay for a repair try of type C\wireless charge
- firmware revers - but I'm worried to brick phone with revert firmware by myself

Anyone has any advices?

Galaxy S23
I am having the same issue with a moisture error when I plug in my phone. and I've done all those same steps and sometimes it will get it to charge without the moisture error but then a little while passing by and I replug it in and it gives me the error again
Galaxy S23
Same issue also