Original topic:

Calendar sync for exchange account doesnt work when permission for notifications are off for samsung email app

(Topic created: 04-17-2024 06:43 AM)
502 Views
jonaslk
Asteroid
Options
Galaxy S24

Hey

Strange situation. I have both a personal google mail (gmail) and a work email (exchange) on my S24. I use the Google Calendar app to show both personal and work calendar. I use Gmail app for personal mail and the Samsung email app for work email.

I do not want to receive any notifications for emails or calendar for that matter.  Silence required 🙂

At the moment my exchange account wont sync meeting/appointments into Google Calendar (or into samsung calendar app) unless I allow the Samsung email app to send notifications in settings. My personal google account sync's fine. Only the exchange account depend on that notification setting. Work mail also sync fine despite notification permissions are off. 

Was not a problem on my S21 - only since I upgraded to S24 a few weeks ago. Same accounts. 

This is very very weird. What can I do?

Regards
Jonas

7 Replies
realaud
Supernova
Options
Galaxy S24

You can set the notification sound to silent, or toggle off "allow sound and vibration".  You will still get notifications, but you won't hear them or feel them.

0 Likes
jonaslk
Asteroid
Options
Galaxy S24

Thx. Would really like to completely avoid notifications though. Hoping there is a way. 

0 Likes
realaud
Supernova
Options
Galaxy S24

Is it possible that it has something to do with the way exchange is configured?  Maybe your company wants you to know when you get mail.

You could always switch mail apps, there are many besides Samsung.  Personally, I use Blue Mail, all my accounts grab mail in the app, but each is color coded (and, of course, named) separately.  I have no notifications enabled because I don't actually need to know when I get email. There are others in the Play store, you just have to find the one that's right for you.

0 Likes
jonaslk
Asteroid
Options
Galaxy S24

I just figured out that setting mail sync to manual kind of solves the problem. Otherwise ill check out some other apps. 

Still get notifications from Samsung calendar though. Even though i use the Google app. Weird that there is no way to disable notification for that Samsung calendar app. 

Thx for your suggestions. 

 

0 Likes
realaud
Supernova
Options
Galaxy S24
Yeah, actually pisses me off that the Samsung calendar can't have notifications turned off. I have always used Google calendar. Since the calendars sync, I figured it was not big deal until I started getting double notifications (one from Google and one from Samsung) for the same events. I just turned off the Google calendar notifications. In the end, I don't care which one is notifying me, as long as I get notified. I never used to get double, it's just since I switched phones from the S10 lite to the A54 - figure it has something to do with either Android 14 or OneUI6.0. or the fact that maybe the notifications were able to be turned off on the older versions. I'll look
0 Likes
jonaslk
Asteroid
Options
Galaxy S24

I believe I had all notifications turned off on my S21.. i prefer no notifications at all 😃

0 Likes
realaud
Supernova
Options
Galaxy S24

Just looked at my S10, Samsung calendar didn't allow notifications to be turned off. In the categories, I had everything turned off that was allowed (as I do now). I have no idea what ringtone notifications are, but they can't be turned off--that is set to "silent" by default. to my knowledge, I've never received a notification of it.

I need a calendar notification, because I tend to forget doctors' appointments and some things that may have been scheduled a long time ago.

0 Likes