Original topic:

Solved-ish, Modes and Routines Cannot get "read notifications allowed" to work

(Topic created: 03-10-2024 12:18 PM)
1540 Views
user1iDFrEQVqf
Cosmic Ray
Options
Galaxy S24
ONEUI 6.1 I keep getting the error "Couldn't perform this action because another operation is preventing it."

This is my only routine. What other app could be interfering with modes and routines? This occurs when I elect any app notification to be read aloud.

image


15 Replies
realaud
Black Hole
Options
Galaxy S24
Try adding snother condition, such as when android auto is connected. Then try to see if the read notifications out loud is allowed. If it is, then delete the Android auto condition and see if it works. I just ran through creating your routine as you had it, and at first, the read aloud was greyed out and not allowed. Then I added the additional condition and was able to allow the read aloud. Then i deleted the Android auto and was still allowed to use the read aloud. Whether it works, is another matter, but the routine was created.
0 Likes
user1iDFrEQVqf
Cosmic Ray
Options
Galaxy S24
Hello, I tested this as described. And unfortunately I'm still getting the same error. I've never configured android auto or set it up.
0 Likes
realaud
Black Hole
Options
Galaxy S24
You can try adding any other condition and see if that eorks. Like I said, the option was greyed out and i got the same message as you did until i added an additional condition snd rhen deleted it. As a point of note, i added the additional condition and the read aloud action and saved it, then went back in and deleted the additional condition but left the read aloud and saved it with no error messages. Then i deleted the ehole routine and started from scratch and the read aliud action was no longer greyed out ehen i recreated the routine.

I can think of no reason why it would be disabled in the first place, as I also have no other conflicting mode or routine that would utilize the read aloud function and, thus, interfere with it.
0 Likes
realaud
Black Hole
Options
Galaxy S24
Also, after you add the notification condition you have choose which apps you want it to apply to. If you only want some, select those. Easiest option is to select all apps. If you only want to read notifications that contain a keyword, add that. I noticed read aloud is inactive unless apps are set.
0 Likes
user1iDFrEQVqf
Cosmic Ray
Options
Galaxy S24
I have all apps selected currently, and it's giving me the same issue. There's some android process outside of modes and routines which is conflicting with the routine.
0 Likes
realaud
Black Hole
Options
Galaxy S24
I'm out if suggestions, then sorry. I currently have no routines of my own, and I ran through you routine to see if I could replicate your issue, and I did. Then I tried a solution that seemed to have worked for me. Even though I had deleted it after I did id, I went back to try it again, and read aloud was still no longer disabled. Did you try rebooting your phone to clear anything that may be interfering?
0 Likes
user1iDFrEQVqf
Cosmic Ray
Options
Galaxy S24
I'll keep troubleshooting, I sent a log via the bug issue reporter to see if they can help. Thank you for the suggestions, as this may help someone in the future.
0 Likes
neilth
Red Giant
Options
Galaxy S24
Open your Recent Apps screen and select Close All, then try it again. If it still fails, boot the phone into safe mode and try it again. If this solves your problem, you then know that it's definitely a process you will need to identify and close or eliminate to get things working as you want.
0 Likes
user1iDFrEQVqf
Cosmic Ray
Options
Galaxy S24
I tried this: within safemode the issue still occurs. What are some diagnostic tools or apps I could use to see the conflict happen? Is there an event log type utility?
0 Likes