cancel
Showing results for 
Search instead for 
Did you mean: 
samsungbeast
Astronaut

Calendar unable to sync with Google calendar after recent update

Hi everyone,
 
After the recent update to the calendar (Version 10.1.00.9),  it does not sync with my Google calendar (and my wife's) anymore.
 
Previously I have added both my Google account and my wife's Google account in the calendar settings, so any Google calendar updates that we do on our respective phones are accurately reflected on our phones through our calendar app (I chose to use the Samsung calendar).
 
After the latest update, whenever myself or my wife add or edit any new events on our Google calendars, I am unable to see these changes reflected on the Samsung calendar anymore.
 
I had encountered such issue before and the solution is
1) Disable the linked Google accounts and add them again
2) Press "Sync Now"
 
However, I can do neither of the steps above in this latest version. It does not allow me to disable the acccounts (only can add new accounts), and the "Sync Now" feature is also greyed out. 
 
I am using a Samsung S8+.
 
Appreciate all the kind souls who can help. Thanks!
7 REPLIES 7
userEawKprrZP6
Constellation

Re: Calendar unable to sync with Google calendar after recent update

Hi, 

 

Have you gotten any answers to your inquiry?  Were you able to figure out how to sync your calendars?  I'm having the same exact problem as you and can't find any solutions!

Reply
Loading...
user487FXEa7Ly
Constellation

Re: Calendar unable to sync with Google calendar after recent update

I had the same problem.  I went to device care/battery/power saving and then I switched from medium power saving to optimized. Now the sync button is no longer grayed out. Let me know if that works for youSmiley Happy

Reply
Loading...
userByOVAFyAyC
Astronaut

Re: Calendar unable to sync with Google calendar after recent update

Worked for me, thanks!

Reply
Loading...
userNyg88YDx1r
Astronaut

Re: Calendar unable to sync with Google calendar after recent update

 

I am facing the same issue, Sync now is Grayed out. Also, there is no option to change the auto sync time, why I don't know. Hopefully it will be resolved in the next update.

 

This is how I was able to sync my calendar manually.

 

1) settings
2) accounts
3) click on the account you like to sync (for me it was my Gmail account)
4) click on sync account
5) turn Off and On Contacts, Calendar, etc.

Reply
Loading...
userkgsiGJwVPT
Astronaut

Re: Calendar unable to sync with Google calendar after recent update

Same here, sync is greyed out, very inconvenient
Thanks for the above work around which works but is cumbersome

Reply
Loading...
userWCFSkIRS2H
Constellation

Re: Calendar unable to sync with Google calendar after recent update

This works!  It has to do with the power saving mode you are in.

"I had the same problem.  I went to device care/battery/power saving and then I switched from medium power saving to optimized. Now the sync button is no longer grayed out. Let me know if that works for youSmiley Happy"

Reply
Loading...
Highlighted
userXQnalGZQAM
Astronaut

Re: Calendar unable to sync with Google calendar after recent update

My wife and I have been suffering this same problem for a couple of weeks, coincidentally since we had a software update. After trying all the remedies we've found on Google and failing, this morning I've found the problem that caused this for us and it was self inflicted by me. A couple of weeks ago we went out all day and late into the night and because I wanted to use my phone for photos/videos I turned on power saving mode and forgot to turn it back. So we're now all sorted.

Hope this helps someone else with this same problem.

Reply
Loading...