cancel
Showing results for 
Search instead for 
Did you mean: 
jgribbin
Halo

Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

I think this started with my upgrade to Oreo, but "Do Not Disturb" is turning on at least once a day even though I have never turned it on myself.

 

I did call Samsung Support once and they had me do a factory reset on the phone. It seemed to work for a day or two, but it's back to doing it daily.

 

I do mute the phone occasionally. The last time was yesterday. I unmuted the phone after my meeting. It was back in Do Not Disturb mode today. I don't recall EVER intentionally using Do Not Disturb.

 

When I go to Do Not Disturb in settings when this happens: Turn on now is switched on, Turn on as scheduled is also  on and is just set to Sun,Mon,Tue, Wed,Thu,Fri,Sat 10PM to 7AM, When I go to the "App rules" page, it is blank.

 

S8, SM-G950U, Baseband - G950USQUCRE9, Experience - 9.0

1 SOLUTION

Accepted Solutions
jgribbin
Halo

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

It's been 2 days now and DND has not turned itself on. I think it came down to uninstalling/re-installing IFTTT.  I'll admit to having tried enough different things that I'm not 100% certain this is what fixed it.

 

One thing I did notice near the end is that even though I couldn't find it in the list of what has permission to control DND is that "Wear OS" can also control DND. When I realized this, it was going to be the next thing I tried.

 

Thanks all...

View solution in original post

Reply
Loading...
29 REPLIES 29
Samsung Moderator
Samsung Moderator

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION


Thank you for the information. I'm sorry you are experiencing this issue. Priority alerts can still come through when you have do not disturb engaged. You may need to customize what alerts are allowed to come through. Let us know if this is helpful. 
 

 

Settings > Sounds and vibration > Do not disturb > Allow exceptions > Custom


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
jgribbin
Halo

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

It isn't helpful.

 

I'm not turning on Do Not Disturb. It's turning on by itself. It did it again this AM.

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

Let's try performing the following:

  • Settings
  • Apps
  • 3 Vertical Dots at the top right corner
  • Show System Apps
  • Do Not Disturb
  • Force Stop
  • Clear Cache
  • Clear Data

Let us know if this helps


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
jgribbin
Halo

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

I seem to follow this OK until I get to "Do Not Disturb".

 

I cannot find an app called "Do Not Disturb". If I look under "Special Access", I find "Do Not Disturb Permissions", but it doesn't seem to have the options you speak of.

 

Looking through "Do Not Disturb Permissions" I may have found a possibility. It seems there are a few apps that I didn't realize have permission to control "Do Not Disturb" and these switches are greyed out, so I can't control them.

 

I uninstalled "SMS, My Car, and Me" and will give it a day or 2 and see if the problem persists.

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

Thank you for letting me know that! Keep me posted. 


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
jgribbin
Halo

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

I guess that didn't work. I just noticed that Do Not Disturb was back on.

 

I also see that Turn on as scheduled was turned off as well. I normally keep that on to keep my phone quiet at night.

 

The other apps that have the control of Do Not Disturb enabled  are:

 

IFTTT, Samsung Experience, and Secure folder.

 

While there are some IFTTT apps that make use of controlling Do Not Disturb setting, I don't see that I have any of these apps installed. I don't know what circumstances Samsung Experience or Secure folder would make use of this switch.

 

I use IFTTT pretty much daily so I don't want to uninstall it, so I've forced stop for the time being. Does is stay stopped until the next reboot?

Reply
Loading...
Supernova

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

Just to confirm, if you go to Settings> Sounds And Vibrations> Do Not Disturb> The scheduled enabling and disabling is completely turned off?

 

Also, give this a try:

  • Settings
  • Apps 
  • 3 Vertical Dots
  • Show System Apps
  • Device Maintenance
  • Force Stop
  • Storage
  • Clear Cache
  • Clear Data
Reply
Loading...
jgribbin
Halo

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

I am trying this as well...except for Clear Data.

 

There is no Data option, just Mobile Data and that has no Clear

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Do Not Disturb is turning on unrequested

JUMP TO SOLUTION

After giving the suggestions a try, have they helped at all?


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...