cancel
Showing results for 
Search instead for 
Did you mean: 
RichardTres3
Asteroid

Incoming calls are not being shown on phone

I've been along time user of Galaxys. Recently my S8+ went thru the newest update (9.0) and its weirdly awesome. Took a day or two to get some features down but now I'm very pleased with it. BUT I've been having trouble recieving most of my incoming calls. Outgoing calls, sending and recieving messages and emails are not affected. But incoming calls dont always show on my phone. Not even in my call log as a missed call. Luckily I have a galaxy watch so I'm able to answer calls on that once I turned off bluetooth and just used the network coverage on it. I heard my issues are update related. Any one else in the same situation? Supposedly there is a system update coming by the end of April or in may that will include a fix for this and other bug fixes. Can anyone confirm or deny this? T.I.A
7 REPLIES 7
userdHSnAd1lw7
Constellation

Re: Incoming calls are not being shown on phone

Thats been happening to me too

Reply
Loading...
userabyXDRgPoF
Constellation

Re: Incoming calls are not being shown on phone

Just noticed it yesterday when I saw voicemail notifications but no incoming or missed call notifications. Please help.

 

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Incoming calls are not being shown on phone

Hello guys.

Have you tried clearing the cache of your Contacts application and ensuring that your permissions are set for the Contacts application to access?

You can locate the steps to clear the cache of an application here: http://www.samsung.com/us/support/troubleshooting/TSG01001151/
 

Hope this finds you well

^SamsungZell


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
RichardTres3
Asteroid

Re: Incoming calls are not being shown on phone

Yes. Even wiped cache partition from the android system recovery menu. No luck. Samsung tech chat is how I found out it may be related to the update. But the tech wasn't able give me a definite answer. And yes I called my network provider and everything was fine with my coverage.

Reply
Loading...
Highlighted
Samsung Moderator
Samsung Moderator

Re: Incoming calls are not being shown on phone

Thank you so much for confirming that information.
 

I would recommend giving these steps a try:
 

Go to Settings > Notifications > Advanced

 

Tap on the 3 dots in the upper right to show system apps.

 

Scroll down the list and tap 'Phone'

 

Turn on 'Do Not Disturb Custom Exception'


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
Chuliganka
Asteroid

Re: Incoming calls are not being shown on phone

I have a Galaxy S7 and have had the same issue with incoming calls not showing up after an update. What fixed the problem for me was turning off the option for HD voice and video calls. To get there on my phone, I go to SETTINGS > CONNECTIONS > Advanced Calling. From there, select the option "Turn on/off HD Voice and Video Calls" and select to turn OFF! I had someone try to call me as soon as I did that (without restarting my phone first), and it worked! Restarting my phone was a temporary fix, and clearing the data from my Phone app didn't make a difference. I hope this helps!

Reply
Loading...
RichardTres3
Asteroid

Re: Incoming calls are not being shown on phone

Yeah this was another suggested fix from Verizon. But the only thing it changed for me was I couldn't get video calls from other galaxy phones. 

 

Restarting my phone wouldn't fix it either. But like I said the factory reset seemed to do the trick. 

Reply
Loading...