cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
userWb4WZNe8w5
Constellation

Phone contacts not showing on incoming calls

JUMP TO SOLUTION
I have a galaxy s8 plus. When I receive incoming calls from a contact in my phone book only their number displays. But when I go in my recent calls both their name and number is there. Like most people I don't know everyone's phone number so when people are calling me, I dont know who they are until after I miss it. Ive already tried restarting my phone. No luxk And I checked for a software update. It's up to date.
1 SOLUTION

Accepted Solutions
Samsung Moderator
Samsung Moderator

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Hey guys,

Go to your Settings>Applications>Search for an application called "Call Protect".


When you open it, select Force stop.


Reply
Loading...
47 REPLIES 47
Samsung Moderator
Samsung Moderator

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Who is your service provider?

Reply
Loading...
userUKsVzVbLS0
Astronaut

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Mine started doing this today also. I have att

Reply
Loading...
userwG9ASodHxV
Constellation

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Mine issue started last week after an update. I too have AT& T.

Reply
Loading...
userhGnQakb7Gn
Constellation

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION
Started for me a few days ago.. I have att
Reply
Loading...
userpRna4U9Jmm
Astronaut

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Did anyone find a solution that works? 

Reply
Loading...
userUKsVzVbLS0
Astronaut

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

I'm having this same problem. It started this morning. I have att.

Reply
Loading...
user4pjNWrGZpq
Asteroid

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Mine started 2 days ago and i have att

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

Have you tried toggling the settings of Call Protect?

Reply
Loading...
user4pjNWrGZpq
Asteroid

Re: Phone contacts not showing on incoming calls

JUMP TO SOLUTION

I do not know what that means.

Reply
Loading...