cancel
Showing results for 
Search instead for 
Did you mean: 
userin9fiY9mMd
Constellation

Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

When I have DND mode enabled WhatsApp calls still come through. In WhatsApp settings I've selected call ringtone as "Silent". When anyone calls me and I got DND mode enabled, the device keeps continuously repeating the message notification sound.

Is this bug in the Samsung Galaxy S9 device or WhatsApp? It is extremely annoying and forces me to turn off mobile data/WIFI during important meetings and at night.

The latest update I got installed is:

G960FXXU4CSE3/G960FOXM4CSE3/G960FXXU4CSE1

 

1 SOLUTION

Accepted Solutions
Highlighted
Honored Contributor

Re: Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

Thanks for reaching out. This forum is for support of US products and customers. As your product is a non-US model and support for these models is very limited, please seek a support team for your area. You can do so by using this link: http://www.samsung.com/visitcountry


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.
Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

View solution in original post

Reply
Loading...
4 REPLIES 4
Highlighted
Honored Contributor

Re: Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

Thanks for reaching out. This forum is for support of US products and customers. As your product is a non-US model and support for these models is very limited, please seek a support team for your area. You can do so by using this link: http://www.samsung.com/visitcountry


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.
Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

View solution in original post

Reply
Loading...
6foot8guy
Constellation

Re: Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

This isn't a solution for U.S. users THAT ARE EXPERIENCING THE SAME ISSUE!!!

 

Please try and give us a normal response and not deflect to some prefabbed response!  There's several posts concerning this issue with no resolution.

 

-thanks

Reply
Loading...
userkrF5rloNgM
Astronaut

Re: Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

I have the same problem and I have a US product. Is there a solution to the DND problem with WhatsApp and Skype? Is it possible to turn off all notifications for all apps with the DND option?

Reply
Loading...
userTCUhnVj9Hn
Constellation

Re: Do Not Disturb not working, Whatsapp calls come through

JUMP TO SOLUTION

I had this problem also, and I think I've finally figured it out for my Samsung Galaxy Note S9 Even on DND my whatsapp was going off, and it happened for my S8 too. I'd done everything from change in app settings (turning off favourite contacts from coming through or callers who phoned multiple times) and changed settings on my phone and nothing worked.

Finally I went to settings>notifications>whatsapp (which I had done before) but this time I realised that for every custom notification I made there was a separate sound profile. Here's a step by step of what I did:

1. Phone Settings>Notifications>WhatsApp
2. There will be a list in front of you
3. If you have custom sounds for contacts, there will be a list of those contacts names and also "message notifications", "group notifications", "call notifications"
4. If you do not have any custom notifications for contacts through WhatsApp then there will only be the latter of those
5. Click on one of them
6. Scroll down to the option "ignore do not disturb" and untick it
7. Go back and repeat for every item on that list you see in step 3 & 4

Hopefully this keeps working, but it explains why it seemed to be inconsistent and random Whatsapp notifications coming through, as I had changed it in "message notifications" and "call notifications" but not the ones on that list named after my contacts. I hope this makes sense - it's been a real relief after ages of putting my phone on airplane mode every night.

Please post if it works or not for you, I'd be curious to know 😊

Reply
Loading...