cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Asteroid

Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

Hello,

 

After my phone was upgraded to Android 10 I started having problems answering phone calls. When the phone rings, the incoming call is not displayed on the screen. I have to access the notifications bar at the top and swipe down on the screen to find the phone app in order to answer the call. It doesn't make a difference whether I'm using another app or not. I've played around with the various call display options - Fullscreen, Pop-up, and Mini pop-up, to no avail. Before this update, when I had an incoming call, the actual call screen would appear and I was able to easily answer the call. I don't understand why the developers thought this was a good option.

 

Please help.

 

Thanks,

 

1 SOLUTION

Accepted Solutions
Highlighted

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

your DND(do not disturb) is on.....
it doesnt display incoming call if DND is on....

 

turn it off from settings or from your quick panelc

View solution in original post

Reply
Loading...
11 REPLIES 11
Highlighted

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

can you try receiving your call in safe mode?

 

also, what is the software version u recently updated to?

u can find it at settings -> about -> software info -> last 4# baseband

 

thanks

Reply
Loading...
Highlighted
Asteroid

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

Hello,

 

Thank you for your response. I haven't tried receiving a call in safe mode and do not know how to do that.

 

The last four digits of the baseband are ETG2.

 

Thanks,

 

Reply
Loading...
Highlighted
Cosmic Ray

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION
Go to settings, then apps, and tap the three buttons on the top right and tap show system apps. Find the phone app and make sure the "apps that can appear on top"setting is turned on.
Reply
Loading...
Highlighted
Asteroid

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

Hello, 

 

I have a permission that reads "Draw over other apps". I assume that's the same thing. It is turned on. But what's weird is that I have 3 phone apps.Screenshot_20200814-173140_Settings.jpg

 

Screenshot_20200814-174100_Settings.jpg

 

Reply
Loading...
Highlighted

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

your DND(do not disturb) is on.....
it doesnt display incoming call if DND is on....

 

turn it off from settings or from your quick panelc

View solution in original post

Reply
Loading...
Highlighted
Asteroid

Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

Ah...I use an app to mute my phone using a specified schedule. I have noticed that even when the app unmutes my phone, DND remains on and I have to manually turn it off. I had not noticed whether or not DND was still on when I received calls. I just tested it and the call appeared in the foreground! Thank you!

Reply
Loading...
Highlighted
Cosmic Ray

Re: Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION
Yes, it's the same thing, just a difference in terminology between mine and yours. I also show three phone apps, have no idea why. One other thing to try is to force stop all three apps, and then clear the data.
Reply
Loading...
Highlighted
Asteroid

Re: Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION

I cleared the cache. I'm a bit nervous about clearing the data. I don't know what may be lost. I need to do some research on that.

Reply
Loading...
Highlighted
Cosmic Ray

Re: Re: Galaxy S9+ Phone App Rings in the Background

JUMP TO SOLUTION
Just FYI, I cleared the data on mine, and I didn't notice any data loss. My contacts and call logs were all there afterwards.
Reply
Loading...