cancel
Showing results for 
Search instead for 
Did you mean: 
Cindy00
Asteroid

New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

I updated the Android version on my Samsung S9 today (that fake 5G), and it broke the Google Maps app on Android Auto. When I plug in my phone, everything loads correctly. 

 
The problem is: when I turn off the phone display --> Google Maps will give the green screen that says "Google maps needs you to change your location settings. When it's safe, check the notification on your phone." 
 
I check my phone to make sure the location is ON, and as soon as I turn the screen on, the green "location" requesting screen goes away and the maps appear again ready to go. I check my settings --- and the location is definitely set to ON. However, I can't use the maps unless my phone screen is on the whole ENTIRE time. What a pain in the rear. Anybody experience this? Solve it yet? 
 
 
Thanks in advance, you would make my year.
 
P.S. This update is a disaster. I absolutely hate it. I wanna go back. Drains my battery like no tomorrow. Reminds me of the Android version on my old galaxy S2. Just saying.
1 SOLUTION

Accepted Solutions
user6S6HgpOjJt
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

Just found out if you disable the "Energy Save Mode" completeley Google Maps and Waze works without issues.

Reply
Loading...
12 REPLIES 12
user6S6HgpOjJt
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

Hi,

 

I have exactly the issue since the latest update.

Google Maps on VW Discover Pro turns green with the message "Google maps needs you to change your location settings. When it's safe, check the notification on your phone". 

 

Google location services are enabled...

 

 

Wait for feedback from Samsung...

Reply
Loading...
Cindy00
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

I used the "Restore" option, and restored the Google Maps setting using data from Samsung Cloud. Google Maps went back to normal, working perfectly fine again. On the flip side, I'm done with this update, it is horrible to say the least. 

Reply
Loading...
user1ehwPfwDLj
Constellation

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

This is very annoying , how do I restore just the maps data from the cloud or do I have to restore the whole phone back to android oreo?

Reply
Loading...
user6S6HgpOjJt
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

Just found out if you disable the "Energy Save Mode" completeley Google Maps and Waze works without issues.

Reply
Loading...
userUMCBtqAXbS
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

**UPDATE**

 

Thank you so much for this suggestion! Turning off the power saving mode also fixed my issue as well!! Glad to know my long hours of searching and trying to do troubling shooting the Google location setting is officially over!

Reply
Loading...
johntbacon
Constellation

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

Testing this out today since I've been experiencing this bizarre problem for the past few days.

Reply
Loading...
userHbtCbJaryg
Astronaut

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

You are an absolute genius, thankyou so much, now i can save fuel and demerit points by getting to exactly where i need to go without a big detour 


@user6S6HgpOjJt wrote:

Just found out if you disable the "Energy Save Mode" completeley Google Maps and Waze works without issues.


 

Reply
Loading...
userUMCBtqAXbS
Asteroid

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

I am having this same issue and have been searching for the past few days for a solution. I'm glad to know I am  not alone. I've searched for hours trying to find a solution, but cant seem to find absolutely anything on the issue.  

Reply
Loading...
userABwAlCewoK
Astronaut

Re: New update broke Android Auto Google Maps - -HELP

JUMP TO SOLUTION

Just wanted to say thanks for this thread.  I also have this issue.  I am going to try disabling the power save mode tomorrow.  Fingers crossed!  There is another thread about this issue here as well: https://forums.androidcentral.com/samsung-galaxy-s9-s9-plus/940368-upadted-my-s9-android-pie-android...

Reply
Loading...