Original topic:

Phone stopped connecting to Android Auto

(Topic created on: 1/8/21 2:20 PM)
userhZ5hu7pHpz
Constellation
Options
Galaxy S9

I had AA working in my new BMW 540i x 2021 pretty well,  but youtube music kept playing on my phone after leaving the car.  The guy at the dealer tried to help me stop the music playing so we did some deleting and reinstalling and now Android Auto completely stopped working.  I see the start button but nothing happens except it makes my phone blink like it is trying to connect.

 
Had some trouble initially but if I recall, I had to download the AA for phone screen app on my Samsung Galaxy S9,+ went to developers mode and clicked a button.  I think it was wirelessly project screen.  I had read that that helps and maybe it did.
 
All was working except for sometimes playing YTmusic when I got out of the car.  Now nothing works. and all we did was uninstall the AA for phone screen and reinstall it.
 
I have deleted my phone from the BMW.
I have deleted everything from my phone (I can't delete AA, in fact I can't even find an icon without the AA for phone screen) but I did delete all updates and cleared the data and cache, so no AA for home screen, just the native AA on my phone.
 
I re-paired my phone to the car.  No problem there.  I click the START ANDROID AUTO and it opens on my phone something that says follow the instructions on your car's screen.  There are no instructions, it just goes back to the start android auto. All it did was say Galaxy S9+ successfully connected to TELEPHONE.
 
A couple of times I got a bluetooth message that said Note- Selected vehicle data is sent to your Android Auto device when you use Android Auto.  CONFIRM NOTE but there is nothing on my phone to confirm so I just click the message on the screen.  Nothing works.  I turn off the car and turn it back on and I get the same message when I try to start AA that says Galaxy S9+ successfully connected to TELEPHONE.  That is all that usually happens when I click start Android Auto.  I get a flicker on my phones screen and it tells me that the Galaxy S9+ successfully connected to TELEPHONE.
 
I see that I am connected to BMW WIFI, but not internet.  Not sure if that is important.  I have the connect wirelessly option clicked when I am in the developers settings on AA.
 
Any help would be appreciated or direct me who to call.
 
  • Error message: Start Android Auto usually brings up a Samsung S9+ successfully connected to Telephone.  Once I got an icon on the screen for AA. I pushed it and it said:  Bluetooth        Note: Selected vehicle data is sent to your Android Auto device when you use Android Auto.  Confirm note or Cancel.
  • Were you able to connect to Android Auto prior to the issue?  Yes
  • Car / head unit make & model: if you use Android Auto on your car display  BMW 540i x 2021..not sure how to get the unit head model
  • Phone make & model:BMW 540i x 2021.
  • Android OS version: Android Version 10
  • Android Auto app version:  Android Auto App version 5.9.604643  Android Auto for Phone screen version 1.1
  • Google Play services version: (Settings > Apps (or Apps & notifications > App info) > Google Play services)
 
Thanks
 
Mike T
0 Likes
0 Replies