cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

I have two S9+ (SM-G965), both unlocked, both on Sprint service. One has U1 firmware and one has Sprint firmware, both latest available. I set Brave Browser (a Chrome variant) as default. Next day, Samsung Internet browser (v 11.2.2.3) has made itself default. I switch it back, ensuring that the setting "Change system settings" inside S.I. is set to "not allowed" and default browser is set to Brave. This occurs on both phones. 

 

Sure enough, next day S.I. is back to default. How do I make it behave? 

1 SOLUTION

Accepted Solutions
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

When "Maximum Power Savings" setting is utilized, only Samsung Internet browser is available. Perhaps SI sets itself as default browser at that point. To avoid having to reset another browser as default after I reset normal (full) power, I will only be able to use "Medium Power Saving" setting. I'm marking this resolved. 

View solution in original post

Reply
Loading...
7 REPLIES 7
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

can you try:

setting -> search -> default app-> browser app -> brave browser?

 

let me know if this works!

Reply
Loading...
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

Thanks, PLTest31000. This is precisely the setting which I set to Brave, only to have Samsung switch it back to Samsung Internet browser. The fact that I set the default browser as I choose and additionally forbid the S.I. app from making system changes seems to indicate that Samsung code is doing something unsavory.

 

Up until this occurred, I was perfectly pleased with the series of Samsung Galaxy phones I have bought and used. This seems to be more than a setting I haven't found. 

Reply
Loading...
Highlighted
Samsung Care Ambassador

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

Hey, 

@Samsung_eu9MHHR

If you haven't already tried this set the brave browser as the default browser. Open system settings, apps, Samsung internet and select Set as default. If it still shows this app is set to open by default for some actions select clear defaults.

I don't know if there are any apps or services that require the specific use of Samsung internet for an action but hopefully they will be able to use brave browser instead. 

Best regards, 

CLF 

Reply
Loading...
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

I believe I may have found the issue. I have had the practice of shutting the phone down in Maximum Power Savings mode while I sleep, and I knew that Samsung Internet was the only browser shown as available in that mode. My current theory is that this mode is what is countermanding my choice for default browser. I will investigate.

 

At this time, I will not designate this as solved until I have found it to be fixed. 

Reply
Loading...
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

When "Maximum Power Savings" setting is utilized, only Samsung Internet browser is available. Perhaps SI sets itself as default browser at that point. To avoid having to reset another browser as default after I reset normal (full) power, I will only be able to use "Medium Power Saving" setting. I'm marking this resolved. 

View solution in original post

Reply
Loading...
Highlighted
Constellation

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION
I too am wanting to switch to using Chrome as my default browser, but I am unable to do so. Please Help
Reply
Loading...
Highlighted

Re: S9 Plus Default browser switches to Samsung Internet

JUMP TO SOLUTION

UserBX, I'm going to have you use the Play Store to first install either Google Chrome or Brave Browser (which runs Chrome opsys but is not tracked by Google). Then, if you avoid using Maximum Power Saving (MPS), just go to the app <Settings> (or swipe top of screen down and hit the <Gear> wheel at top, right); select <Apps>, then top, right <3 Dots>, <Default apps>, <Browser>. Choose Chrome or Brave, then <Back> <Back> <Back> or just <Home>.

 

As long as you don't set MPS, this will keep your selected browser as Default. If you do engage MPS and then go to normal power, you'll have to reset the default browser as I describe above. 

Reply
Loading...