cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
The_Chemist
Cosmic Ray

Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

I hope someone can help with this frustrating issue.

 

My S9 Plus just received Android 9 Pie update today.  After the update my "Samsung Caller ID" Smart Call stopped displaying the name of any incoming caller not in contacts when the call comes in. 

 

Smart call still will display names of places or people called not in contacts on outgoing calls.  I don't get it!

 

Smart call is turned on in the phone settings. 

 

I found the app and allowed permissions to phone and contacts, but still not working.

 

I looked on my Note 9 as well and found the Smart Call app.  It does not have permissions granted for phone and contacts, but yet it works.  So, I don't think that is the problem.  Apparently PIE messed something up on my S9 Plus. 

 

Does anyone know how to fix this, or do we have to wait for an update?

 

Thanks in advance to all who reply.

1 SOLUTION

Accepted Solutions
Samsung Moderator
Samsung Moderator

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone

Reply
Loading...
45 REPLIES 45
Samsung Moderator
Samsung Moderator

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone

Reply
Loading...
The_Chemist
Cosmic Ray

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

I will try that. Thank You. 

 

Now on that I want an incoming marketing call to try it out, I probably won’t get one.  


@SamsungLarry wrote:

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone


 

Reply
Loading...
The_Chemist
Cosmic Ray

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

That fixed it.  Thank you very much!

Reply
Loading...
userOIXCcGqw4C
Asteroid

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

It didnt work for me. Mine still doesnt work

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

@userOIXCcGqw4C Have you tried wiping the cache partition on your phone?

Reply
Loading...
userOIXCcGqw4C
Asteroid

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

Yes i did

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

What carrier are you currently using?

Reply
Loading...
The_Chemist
Cosmic Ray

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION
My carrier is Verizon. The smart call worked flawlessly before the PIE update. I do not have Verizon Call Filter app installed, so nothing should be interfering with Smart Call...
Reply
Loading...
userYH337BsRFk
Astronaut

Re: Smart Call not working on incoming calls after PIE update

JUMP TO SOLUTION

How did you manage to uninstall the Verizon CiD app? I have one Verizon SM S8 and I cant load its built in Smart call

Reply
Loading...