JUMP TO SOLUTION Solved

Original topic:

Smart Call not working on incoming calls after PIE update

(Topic created on: 5/7/19 3:49 AM)
The_Chemist
Cosmic Ray
Options
Galaxy S9

I hope someone can help with this frustrating issue.

 

My S9 Plus just received Android 9 Pie update today.  After the update my "Samsung Caller ID" Smart Call stopped displaying the name of any incoming caller not in contacts when the call comes in. 

 

Smart call still will display names of places or people called not in contacts on outgoing calls.  I don't get it!

 

Smart call is turned on in the phone settings. 

 

I found the app and allowed permissions to phone and contacts, but still not working.

 

I looked on my Note 9 as well and found the Smart Call app.  It does not have permissions granted for phone and contacts, but yet it works.  So, I don't think that is the problem.  Apparently PIE messed something up on my S9 Plus. 

 

Does anyone know how to fix this, or do we have to wait for an update?

 

Thanks in advance to all who reply.

52 Replies
userPn9b8HVQf3
Constellation
Options
Galaxy S9

My caller ID hasn't been working since last Wednesday. Can't get it figured out either

0 Likes
user0NEekad4LX
Asteroid
Options
Galaxy S9

I tried this and it works.  

Go to Settings; Apps; Call Protect App and disable or force stop it

Found it on another thread.  I just disabled it and the calls now show

who is calling.

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

@user0NEekad4LX wrote:

I tried this and it works.  

Go to Settings; Apps; Call Protect App and disable or force stop it

Found it on another thread.  I just disabled it and the calls now show

who is calling.


I have tried that numerous times.  It does initially work, but the issue always comes back. 

 

It is not a permanent fix, at least in my case  

0 Likes
userzpOZ34EXzB
Constellation
Options
Galaxy S9

I want to be sure we are talking about the same problem (Galaxy S8, Italy)

 

 

After Pie update, the Smart Call app from Samsung does not stay enabled:

after you enable Smart Call from "Call settings", it stays enabled only for few hours. During these few hours, it works properly.

However, after a while, the "Smart Call" settings switches to "Disabled" by itself.

 

PS: In my case, the caller ID from the carrier works perfectly.

 

 

 

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

@userzpOZ34EXzB wrote:

I want to be sure we are talking about the same problem (Galaxy S8, Italy)

 

 

After Pie update, the Smart Call app from Samsung does not stay enabled:

after you enable Smart Call from "Call settings", it stays enabled only for few hours. During these few hours, it works properly.

However, after a while, the "Smart Call" settings switches to "Disabled" by itself.

 

PS: In my case, the caller ID from the carrier works perfectly.

 

 

 


My smart call does stay enabled. It just stops working after a few calls  

 

Caller ID from Verizon does work all the time, but they charge $3.00 / month. 

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

Samsung may have fixed this issue.

 

Earlier this week, I received an update for Samsung Experience.  

 

The next day I received 3 sp@m

Spoiler
 

calls. Every call was identified, and I was given the option to report the call  

 

I'm not sure why this site flagsvrhe word "sp@m" when you try to post. That's why I have to use the @ sign. 

 

Later in the week I received a second update for Samsung Experience.   I was hoping what may have been fixed was not broken by the second update. Since then, I received 2 more sp@m calls  They were both identified. 

 

I'll continue to monitor and post back here. I'm hoping Smart Call is finally fixed after Pie broke it  

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

I do believe that Samsung has finally fixed this issue caused by the Pie update. 

 

The recent Samsung Experience (Android Overlay) update that was sent out appears to have fixed whatever was broken. 

 

Every single call that I have received since the Samsung Experience update, that was not in my contacts,  has been identified.

 

I will continue to monitor and post back, but I think Samsung fixed the issue. There must have been a patch in the Samsung Experience update to fix the broken code.

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

Smart call is not fixed. I had 3 incoming calls today. All 3 said unsaved and did not give me the option to report the call as sp@m. 

 

I thought they fixed it. Oh well. I'm really frustrated with this. 

 

I own so many Samsung products including a $6,000 75" Q9F TV. I expected more from Samsung. 

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

Okay, I was wrong. I did have the option to report the call and block the number. The options were under (!) Info. Apparently Smart Call just has no caller ID information for that number which called 3 more times today. My phone just displays "unsaved". I was able to block it. So I am thinking that Samsung did their diligence and fixed the broken code. 

 

Now for the trick of the tail, I'll have to switch my SIM card over to my Note 9, which also got the Samsung Experience update and see if Smart Call now works on it as well.  

0 Likes
userkpPVdZw4x1
Constellation
Options
Galaxy S9

I think I found a solution, hope it can help: there is a new update available form Germany (no brand) on SAMMOBILE for Galaxy S8 : GF950FXXU4DSDA/GF950FXXU4DSD6 installed almost a week ago, and the problem seems to be solved.

0 Likes