JUMP TO SOLUTION Solved

Original topic:

Smart Call not working on incoming calls after PIE update

(Topic created on: 2/19/19 3:31 PM)
The_Chemist
Cosmic Ray
Options
Galaxy S9

I hope someone can help with this frustrating issue.

 

My S9 Plus just received Android 9 Pie update today.  After the update my "Samsung Caller ID" Smart Call stopped displaying the name of any incoming caller not in contacts when the call comes in. 

 

Smart call still will display names of places or people called not in contacts on outgoing calls.  I don't get it!

 

Smart call is turned on in the phone settings. 

 

I found the app and allowed permissions to phone and contacts, but still not working.

 

I looked on my Note 9 as well and found the Smart Call app.  It does not have permissions granted for phone and contacts, but yet it works.  So, I don't think that is the problem.  Apparently PIE messed something up on my S9 Plus. 

 

Does anyone know how to fix this, or do we have to wait for an update?

 

Thanks in advance to all who reply.

1 Solution


Accepted Solutions
Solution
SamsungLarryK
Samsung Moderator
Samsung Moderator
Options
Galaxy S9

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone

View solution in context

52 Replies
Solution
SamsungLarryK
Samsung Moderator
Samsung Moderator
Options
Galaxy S9

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone

View solution in context

The_Chemist
Cosmic Ray
Options
Galaxy S9

I will try that. Thank You. 

 

Now on that I want an incoming marketing call to try it out, I probably won’t get one.  


@SamsungLarryK wrote:

Hey, give this a try. 

 

Go to Settings > Apps > Show system Apps (click on the 3 vertical dots upper right of screen) >
 Smart Call > Storage > Clear Data and Clear Cache. 
 Restart Phone


 

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9

That fixed it.  Thank you very much!

0 Likes
userOIXCcGqw4C
Asteroid
Options
Galaxy S9

It didnt work for me. Mine still doesnt work

SamsungQue
Samsung Moderator
Samsung Moderator
Options
Galaxy S9

@userOIXCcGqw4C Have you tried wiping the cache partition on your phone?

userOIXCcGqw4C
Asteroid
Options
Galaxy S9

Yes i did

0 Likes
SamsungJace
Community Manager
Community Manager
Options
Galaxy S9

What carrier are you currently using?


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
The_Chemist
Cosmic Ray
Options
Galaxy S9
My carrier is Verizon. The smart call worked flawlessly before the PIE update. I do not have Verizon Call Filter app installed, so nothing should be interfering with Smart Call...
userYH337BsRFk
Astronaut
Options
Galaxy S9

How did you manage to uninstall the Verizon CiD app? I have one Verizon SM S8 and I cant load its built in Smart call

0 Likes