cancel
Showing results for 
Search instead for 
Did you mean: 
JWilsonTL
Cosmic Ray

Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

I just found out that I had 7 new voicemails - but yet, I got NO notifications that I had any. 

 Anyone know how to fix this?  

 This 9+ is NOT what its cracked up to be. 

I'm sorry I ever bought it with all of these issues.  

1 SOLUTION

Accepted Solutions
userciP3CizoOy
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

It's not as simple as "my notifications are on".  Notifications in Oreo are a bit more complicated than before.

 

Do this:

 

1.  Go to Settings.  Go to Notifications.  Select "Advanced" in the upper right corner.

 

2.  Find the voicemail app and select it.

 

3.  First, make sure "App icon badges" are turned "on".

 

4.  You should see the word "Categories".  Underneath that, you should see "General Notifications" and "Voicemails".  These represent the different notification channels within the voicemail app, and you need to make sure you have the settings right in both of them.  So, do the following for both "General Notifications" and "Voicemails".

 

5.  After selecting each, make sure the toggle is set to "on".   Then, select "Importance" and set it to "High"  Then, under "Advanced", set app icon badges to "on".

 

It sounds more complicated than it is.  But if you have your phone in front of you and you follow the above steps, you'll see all the different things you need to set the exact right way in order to get your voicemail notifications.

 

 

View solution in original post

Reply
Loading...
91 REPLIES 91

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Greetings,

While the hardware is great, the software experience is not what many were hoping for.  

 

 I have found several bugs which have greatly impacted my user experience.    Some of them I can learn to live with.   The others are just extremely frustrating.  

 

 

~ Former N6p, Pixel1 owner who tried an s9+ ~ With Android, The software experience is everything. Good specs doesn't mean great device. In the end, it's the software experience that makes or breaks hardware. I've dumped the S9(minus) and gone back to a device that receives actual support, regular updates and bug fixes. DONE WITH SAMSUNG - SOLD THE S9(minus) - YOU GUYS ARE LIARS!
Reply
Loading...

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Press and hold the "1" key in the dialer. Ensure your VM is set up properly. Outgoing message. Etc.

 

 

~ Former N6p, Pixel1 owner who tried an s9+ ~ With Android, The software experience is everything. Good specs doesn't mean great device. In the end, it's the software experience that makes or breaks hardware. I've dumped the S9(minus) and gone back to a device that receives actual support, regular updates and bug fixes. DONE WITH SAMSUNG - SOLD THE S9(minus) - YOU GUYS ARE LIARS!
Reply
Loading...
userTDDFjEN6GM
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Why is reading comprehension such an issue?  This is not a solution to the stated question.  Dialing '1' may get you to your service voicemail but it will not, in my experience, provide an option to get vm push notification working on your phone.  I have the same issue and it's been a frustrating lesson, complete with support personnel that misinterpret the issue.  Like here.  So far, the unfortunate answer seems to be you have to use a vm app from your vm service provider.  In my case, no such option provided(Ting, a network reseller).  Newer Apple(ios) devices seem to work just fine though.  So there must be some method available to enable push notifications of voicemail.

Reply
Loading...
userqytNGED3tk
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Hi. I had the same issue, I had 5 new voicemails and did not know it. I use Verizon as my carrier and this worked for me.

 

Go to settings > Notifications > App icon badges, select on. Then you can select which apps to receive notifications from. Go to voicemail and turn it on. I hope this helps.

 

 

Reply
Loading...
MisterC
Asteroid

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

My notifications are turned on. THe VM app is not in that list. I can only find it under system apps and the option for "Set as default" is greyed out.  I get NO VM notifications at all. It is frustrating to pay all of that money for a phone with no VM notifications. I never had this problem before with ANY smartphone. My last phone was a Galaxy S5 and it had the VM icon on the screen along with the phone icon. my S9+ should have the same.

 

My provider is Wing, and they resell Sprint. 

Reply
Loading...
userciP3CizoOy
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

It's not as simple as "my notifications are on".  Notifications in Oreo are a bit more complicated than before.

 

Do this:

 

1.  Go to Settings.  Go to Notifications.  Select "Advanced" in the upper right corner.

 

2.  Find the voicemail app and select it.

 

3.  First, make sure "App icon badges" are turned "on".

 

4.  You should see the word "Categories".  Underneath that, you should see "General Notifications" and "Voicemails".  These represent the different notification channels within the voicemail app, and you need to make sure you have the settings right in both of them.  So, do the following for both "General Notifications" and "Voicemails".

 

5.  After selecting each, make sure the toggle is set to "on".   Then, select "Importance" and set it to "High"  Then, under "Advanced", set app icon badges to "on".

 

It sounds more complicated than it is.  But if you have your phone in front of you and you follow the above steps, you'll see all the different things you need to set the exact right way in order to get your voicemail notifications.

 

 

View solution in original post

Reply
Loading...
usert3KyKJVIkh
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

I too am having this issue.  I did everything you said in this post.  When I get into the voicemail app notification screen ON is highlighted blue. App Icon Badges is highlighted blue.  I see a greyed line saying categories-------- and underneath that is "this app hasn't sent you any notifications."  EXACTLY!!!   Can you help?

Reply
Loading...
Supernova

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Hey, @usert3KyKJVIkh, could you provide us with some more information about your device so that we can look into what may be causing your lack of notifications?

* Model Number

* Baseband Version

* Carrier

 

You can find this information in Settings > About Phone. Thanks!


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.


Reply
Loading...
usert3KyKJVIkh
Constellation

Re: Voicemail notification / symbol not working on 9+

JUMP TO SOLUTION

Model# SM-G96OU1

Baseband# G96OU1UEU1ARBG

Carrier is Credo (I believe they use Sprints platform)

 

Thanks for your efforts.

Reply
Loading...