cancel
Showing results for 
Search instead for 
Did you mean: 
userikwlqOOTqD
Asteroid

option to sync contacts has disappeared from "Sync Account" menu

I've been wrestling with this for days and tried many solutions but can't find one that works.

Symptoms from my S9 (running Android Version 9 and up to date on system updates) ...

1. I noticed that contacts that I was entering in my CRM (that pushes to Google Contacts) were no longer appearing.  These had been syncing fine ever since I purchased the phone (18 months ago?)

2. When I went to Settings>Accounts>Google>Sync Account there is no longer an option to sync Contacts.  There is: Google Play Music, Calendar, Chrome, People Details, Google Fit Data, Gmail.

But NOTHING for CONTACTS.

3. When I go to Contacts>Manage Contacts>Sync Contacts               There is NO google account listed.  If I try to "Add Account" and put in my google account info it tells me "This account already exists on your device."

When I sign on to Contacts from the web my contacts are still there but my phone will not sync with them.

I've tried....

1. removing and adding my google account from my phone

2. disabling google sync, rebooting, re-abling

3. #1 & 2 together

4. Downloading Google Contacts from the Play Store (the icon on my phone is orange v 10.1.02.23, the one in the store is blue v 3.8.4.266256636 and does NOT update the already installed version. Any idea what the difference in these 2 is?  And I do not seem to be able to make the blue one the default app for contacts and connot remove the orange app)

5. Downloading contacts sync from APK

6. Downloading some of the sync apps from the App store.

 

Seems the root is that Contacts is not seeing/recognizing my google account and my google account is not recognizing the Contacts app on my phone.  HELP!  I've spent HOURS trying to debug this!!!

 

TIA

 

6 REPLIES 6
Honored Contributor

Re: option to sync contacts has disappeared from "Sync Account" menu


@userikwlqOOTqD wrote:

I've been wrestling with this for days and tried many solutions but can't find one that works.

Symptoms from my S9 (running Android Version 9 and up to date on system updates) ...

1. I noticed that contacts that I was entering in my CRM (that pushes to Google Contacts) were no longer appearing.  These had been syncing fine ever since I purchased the phone (18 months ago?)

2. When I went to Settings>Accounts>Google>Sync Account there is no longer an option to sync Contacts.  There is: Google Play Music, Calendar, Chrome, People Details, Google Fit Data, Gmail.

But NOTHING for CONTACTS.

3. When I go to Contacts>Manage Contacts>Sync Contacts               There is NO google account listed.  If I try to "Add Account" and put in my google account info it tells me "This account already exists on your device."

When I sign on to Contacts from the web my contacts are still there but my phone will not sync with them.

I've tried....

1. removing and adding my google account from my phone

2. disabling google sync, rebooting, re-abling

3. #1 & 2 together

4. Downloading Google Contacts from the Play Store (the icon on my phone is orange v 10.1.02.23, the one in the store is blue v 3.8.4.266256636 and does NOT update the already installed version. Any idea what the difference in these 2 is?  And I do not seem to be able to make the blue one the default app for contacts and connot remove the orange app)

5. Downloading contacts sync from APK

6. Downloading some of the sync apps from the App store.

 

Seems the root is that Contacts is not seeing/recognizing my google account and my google account is not recognizing the Contacts app on my phone.  HELP!  I've spent HOURS trying to debug this!!!

 

TIA

 


Just make sure contacts are safe before doing this, but it shouldn't mess around with them.

 

Tap and hold contacts app shortcut on your home screen. Then when context menu appears, tap on App info. Then go to storage and clear data

 

See if Google contacts option appears in contacts app, if not then remove google account, restart device.  Add google account back again by tapping on Play Store.

 

If not fixed:

Wipe cache partition:

1) Turn off the device.
2) Press and hold the Volume Up key and the Bixby key, then press and hold the Power key.
3) When the Android logo displays, release all three keys.
4) An 'Installing system update' message will show for some seconds before the Android system recovery menu options appear.
5) Press the Volume down key several times to highlight wipe cache partition.
6) Press Power key to select.
7) Press the Volume down key to highlight yes, them and press the Power key to select.
8) When the wipe cache partition is complete, Reboot system now is highlighted.
9) Press the Power key to restart the device.


Reply
Loading...
userikwlqOOTqD
Asteroid

Re: option to sync contacts has disappeared from "Sync Account" menu

unfortunately none of that worked.  

I had tried your first solution before and just tried wiping the cache partition (several times)

1. delete google account

2. clear contacts data

3. turn off

4. wipe cache partition

5. reboot

6. open contacts and add Google account

no results

Google contacts does STILL not appear as an account under CONTACTS

Contacts does STILL not appear as an option unter Accounts>Google>Sync account

 

any other ideas?

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: option to sync contacts has disappeared from "Sync Account" menu

Hello @userikwlqOOTqD,

 

Are you saving your contacts to your google account? If you pull up a contact on your device and you look at the very top of the screen, it will show where each contact is being saved under (example: Phone or ****@gmail.com).

Reply
Loading...
userikwlqOOTqD
Asteroid

Re: option to sync contacts has disappeared from "Sync Account" menu

those tabs no longer show in my contacts.  Contacts does not recognize my google account AT ALL.  and if i try to add the account it tells me it already exists on my phone.

Reply
Loading...
Samsung Moderator
Samsung Moderator

Re: option to sync contacts has disappeared from "Sync Account" menu

That's a bummer! Try adding a new contact and see if you see those tabs on the top of the screen.

Reply
Loading...
userikwlqOOTqD
Asteroid

Re: option to sync contacts has disappeared from "Sync Account" menu

So the problem has been solved. I'm not sure what I did but I now have access to my google contacts. 

I opened up a bunch of privacy settings and hours later it was working so I'm thinking that was it but I have no idea specifically what I did that made the change. I might try tightening up my privacy again (slowly) and see if I can find the setting that changed things.

How VERY frustrating!  But I'm glad to have my sync back.

Thanks to all who replied for your help.

Reply
Loading...