cancel
Showing results for 
Search instead for 
Did you mean: 
Asteroid

ports used for RCS ?

I'm using the Samsung messages app on the sprint network. It's configured for RCS, however, when I'm on my home wifi network I don't receive messages from other RCS users.  I do not have any outbound firewalls configured. Are there inbound connections that are expected? Are there specific ports I should be looking at? I can set up a connection on TCP port 5061 no problem which is what some Internet users suggested might be the right thing but RCS still does not work.  Note I can send messages, I just cannot receive them, nor see any of the 'online, delivered,read' indicators for messages.  I have been unable to find anything that talks about how Samsung has implemented this, though I know google has moved its messaging app to port 443 to avoid the firewall issue.  And yes my phone has taken all available updates.

3 REPLIES 3
Constellation

Re: ports used for RCS ?

For me, I got messages for web to connect from my desktop to my phone when they were on the same network by creating two new windows firewall rules on the PC that I was trying to utilize messages for web.
 
Incoming rule: allow UDP from all local ports and these remote ports 443, 1900, 50759, 39678 (I think the only port that matters is 1900, but have it working so don't want to change it). I also allowed edge traversal under advanced, but do not know if this is contributing to the success or not yet. it could be unnecessary and less secure; I do not know yet.
 
Incoming rule: allow TCP from all local ports and these remote ports 443, 1900, 50759, 39678 (I think the only port that matters is 1900, but have it working so don't want to change it). I also allowed edge traversal under advanced, but do not know if this is contributing to the success or not yet. it could be unnecessary and less secure; I do not know yet.
 
I also saw a post (link after) to somebody that solved the same issue, but at the router level on his DD-WRT router. He said to go to the following menu item (will vary by router though) to find something like "Network > DHCP and DNS > Advanced Settings: UNcheck "Filter useless"
Which has the effect of turning off the default router behavior of: "Do not forward requests that cannot be answered by public name servers". Link to this guy's full comment: https://support.google.com/messages/thread/11640370?hl=en&msgid=29556371
 
FYI: I did not have to change a single thing on my phone.
 
Hopefully this will help someone else having Messages for Web linking or connection issues to a device using the same network (like over wifi), but who does not have any issues in the same location when turning off the phone's wifi to use mobile data.
 
That quirk has been driving me bonkers for at least a year.
Reply
Loading...
Constellation

Re: ports used for RCS ?

@slyatmit -- if you haven't found a solution yet, try what worked for me

Reply
Loading...
Asteroid

Re: ports used for RCS ?

Thanks for the response. My router generally blocks all incoming traffic and outbound (internally initiated traffic) is allowed. After testing various ports, I did stumble across the note about "filter useless".   I'm using Samsung Messages and basically if I had the chat feature on it wouldn't work when I was on my wifi, if I forced it to SMS of course things worked fine (I think it actually runs over port 5061). Turns out in dnsmasq.conf on linux it actually outright says that if you turn this on it will block SIP.  RCS uses SIP and MSRP.  I certainly didn't remember when I set up my dnsmasq filters.

 

# Uncomment this to filter useless windows-originated DNS requests
# which can trigger dial-on-demand links needlessly.
# Note that (amongst other things) this blocks all SRV requests,
# so don't use it if you use eg Kerberos, SIP, XMMP or Google-talk.
# This option only affects forwarding, SRV records originating for
# dnsmasq (via srv-host= lines) are not suppressed by it.

#filterwin2k

 

So maybe this will help other folks, because 'filter useless' didn't mean much to me Smiley Happy

Reply
Loading...