Original topic:

Active 2's Bluetooth "Phone Call" Setting Deafens Pixel 3's Google Assistant

(Topic created on: 4/11/21 3:25 PM)
Anonymous
Not applicable
Options
Galaxy Watch

Hello all,

 

I've experienced the problem stated in the title ever since I purchased the Active 2 some months ago. I've spoken with Samsung support over the phone to troubleshoot the issue, and they led me to some solutions that temporarily solved the problem (i.e., the issue resurged later the same day). I'm writing to get a permanent solution to this issue. I'll start by describing the issue more in-depth below, as well as the temporary solutions given to me by Samsung's tech support. 

 

Watch: Active 2 (0334) on Tizen ver 5.5.0.2

Phone: Pixel 3 on Android 11

Steps to reproduce the issue: Pair watch to phone via Bluetooth, then navigate to Bluetooth settings on your phone, select the connected watch, and enable "Phone calls" and "Input device" options (as shown in the image below). Then use the active edge to activate the Google Assistant. The assistant should not be able to hear a word that you are saying.

1.png

After following the steps above, the issue that I face is that when I use the Pixel 3's active edge feature to activate the Google Assistant, the Assistant is not able to hear a word that I say (even despite me holding the phone close to my mouth).

Because of this observed behavior, I presumed that the Assistant was actually using the watch's mic as input, so I used active edge to launch the Assistant again, this time speaking with the watch close to my mouth. No luck--the Assistant still didn't hear a word I said.

If I deactivate the "Phone calls" option in my bluetooth settings (as shown in the attached image), then the Google Assistant CAN hear me perfectly and works as expected.

2.png

 

Samsung's technical support acknowledged the issue and recommended that I navigate to Settings > Apps and Notifications > View all apps > Menu > Show system apps > Bluetooth > Storage and Cache > Free storage space and clear cache. As mentioned, this worked for a couple of hours (as in the Google Assistant worked perfectly, even with the "Phone calls" option enabled), but afterward reverted back to not working.

 

Interestingly enough, enabling the Google Assistant to activate with the "Ok, Google" phrase works 100% of the time, even with the "Phone calls" option enabled. I suspect that "Ok, Google" defaults to the phone's microphone 100% of the time, whereas the Active Edge doesn't. 

 

Anyways, please forgive the long post. Is there anyone who can please provide some insight, and perhaps even a viable permanent solution? 

 

Let me know if further clarification is needed. Thanks.

0 Likes
3 Replies
Options
Galaxy Watch

No solution, but just reporting that I use the same settings, and activating the GA with the edge sensor works fine on my Pixel 4 (Android 10) paired with GW. I have the "OK Google" activation disabled. I can use the GW for handsfree calls and edge activation of GA in any order.

Since you can get it to work for a while after clearing the cache, could it perhaps be linked to some other app that you use later that makes it go wrong?

Anonymous
Not applicable
Options
Galaxy Watch

Thank you for taking the time to read my post and to respond! Very interesting to know that you don't face this issue on your Pixel 4. You may be onto something.

I rebooted my Pixel 3 into safe mode, connected to the watch, enabled the two settings I mentioned in the post above, and then activated the Google Assistant via the Google launcher's search bar and had no issues--the Assistant heard me perfectly. Safe mode blocks active edge, which is why I had to use the search bar to invoke the Assistant. 

 

Then, I exited safe mode, re-connected the watch with the same Bluetooth settings and noticed that the Google Assistant no longer worked. Perhaps there's an app that I've granted mic/phone call permissions to that's hijacking the mic... 

0 Likes
Anonymous
Not applicable
Options
Galaxy Watch

Update: After exiting safe mode, I systematically went through each app that has phone/mic priveleges and disabled them to see if the Assistant would work or not. The Assistant refused to work, still. 

I'm now just as confused as I was when I first posted.

0 Likes