Original topic:

Battey drain

(Topic created on: 10/25/20 9:38 AM)
usera2ZIslmFwK
Astronaut
Options
Galaxy Watch

I recently updated my galaxy watch 2. Since the update my watch as been dieing very quickly. Last night I went to bed with 50% and woke to it being dead. Why is this happening and how to I fix it?

3 Replies
SHADOWGATE
Supernova
Options
Galaxy Watch
make sure none of the "pairing and finding" options have been changed. Sounds like it's being bled dry when not in use and that's usually from a background application or the device itself trying to constantly stay connected whether for push notifications or background processes. I'd go through and see which ones are running constantly that aren't needed while sleeping and put them to sleep
0 Likes
JohnRichard
Cosmic Ray
Options
Galaxy Watch

Check Background Apps and Stop Them.

 

In my case, the stock Gallery App was stuck running and sucking down all of the battery life, even AFTER several shut downs & reboots!

 

Here's how:

On Phone

Open Galaxy Wearable App

Press the top summary where it shows the watch face, battery, etc.

Press Battery

Look at the Apps near the bottom under "Battery Usage Since Last Charge"

If you find a high-usage app, Press it, then Press "Force Stop" (bottom-right).

0 Likes
JohnRichard
Cosmic Ray
Options
Galaxy Watch

Update:  Two months later it happened again. Two nights in a row the battery lost all power.

 

In this instance, I took two steps and it has resolved the problem.

 

Short Version:  

  1. I Forced Stop on Samsung Health in the Galaxy Wearable App
  2. I Turned off Mobile Networks on the Watch (I have an Active 2 LTE model but do NOT have an LTE/Data Plan).

 

Long Version:

Samsung Health was shown near the top of the list with 25% usage, although I had not used the Watch or Samsung Health any differently.

 

I repeated the steps in my prior post and Pressed "Force Stop" on it.

 

My Active 2 is an LTE version, although I do NOT have a Data Plan for it and have never activated it. So in this instance, I also did something different too.  

 

In the Galaxy Wearable App, you can Add/Manage/Remove Mobile Plans.  However, if you don't have a Mobile Plan, there doesn't appear to be a place to turn off the Mobile Connection. You can only click "Use Code" or "Skip".  I had opened it then pressed "Skip", but there were no other options. So...

 

  1. On my Active 2 LTE Watch:
  2. Pull Down
  3. Settings (gear icon)
  4. Connections
  5. Mobile Networks
  6. "Are your watch & phone plans from the same service provider?": Clicked "X" (not checkmark)
  7. By default, "Auto" was ON !
  8. I Toggled Mobile from Auto to Off.

I did NOT do the following, but I'm noting this additional step here for future reference as other users/threads have indicated it helped:

  1. In the Galaxy Wearable App:
  2. Backup
  3. FactoryReset
  4. Restore
0 Likes