Original topic:

Can't pair or update Samsung Galaxy Watch Active 2

(Topic created: 05-29-2021 05:00 AM)
userj6hhI2HiUg
Constellation
Options
Galaxy Watch

Hi everyone,

I've searched all over the Samsung forum, Reddit, YouTube and contacted Samsung technical support. My last resort is to try and see if someone here can help me, if not I'll return the watch.

I've been trying the pair my Samsung Galaxy Watch Active 2 40mm Aluminum model SM-R830 with my phone a Samsung Galaxy m31s and it remains stuck on finishing pairing. I give all permissions to the wearable app, active 2 plugin app and that other app who's name I forgot. Below you can find an overview of what I've already tried.

  • reset network settings on my phone and reset the watch.
  • unpaired watch from phone Bluetooth.
  • try option with scanning near devices.
  • manually disconnect and reconnect the to watch during pairing process when it's on the last dot.
  • Cleared cache and data on the wearable app, uninstall and reinstall the wearable app.
  • Restart the phone and restart the watch.
  • tried pairing with the wi-fi disabled on my phone.
  • let the pairing process run it course, it ran for over an hour and once overnight.

  • tried pairing with a 2 different phones a Motorola G9 Plus and a Samsung Galaxy S20 using all different methods mentioned here.

  • Tried to use the watch without pairing, connected it with wi-fi and perform a OS software update, it finds a update, but after downloading and installing, it restarts and tells me that it couldn't install the update and that I need to try it again later. I've tried it several times, I've performed several resets of the watch, but it never installs the update.

Samsung support told me to either go with the phone to the nearest service center, which is impractical due to the distance or return the watch. I want to return the watch, but not before I tried asking here if someone knows how to solve this.

0 Likes
0 Replies