Original topic:

Event Complication All Day Events Always 1 Day Early

(Topic created: 04-18-2024 01:14 PM)
460 Views
Terrapin69
Astronaut
Options
Galaxy Watch
Has this been solved yet?

No matter which stock watch face I use, when I add the event Complication, it shows all day events for tomorrow. I have no notifications set and have tried disabling and enabling the permissions. Sucks. Such a simple thing and it just doesn't work.

Clicking on the complication brings up the calendar and those All Day Events are where they should be... tomorrow.

Not doing a hard reset for this either.

Anyone have luck fixing this annoying issue?/
0 Likes
7 Replies
realaud
Supernova
Options
Galaxy Watch

I don't know for sure, but maybe the event complication shows upcoming events, not current events, thus your next event would be the next day since, presumably, you are already into today's events.  Also might have something to do with what your default notification time is on your calendar. If it's set to notify you one day in advance, that might be what's showing in your complication.  I can't be sure, though, as I don't use that particular complication.

0 Likes
notforhire
Honored Contributor
Options
Galaxy Watch

I never use the event complication, so I can't say. hopefully someone else here can shed some light on this. not that this should impact it, but what calendar are you using (calendar, not calendar app)?

0 Likes
Terrapin69
Astronaut
Options
Galaxy Watch
Google Calendar
0 Likes
notforhire
Honored Contributor
Options
Galaxy Watch

and you're not having any problems on your phone or the web with the all day events, correct?

0 Likes
Terrapin69
Astronaut
Options
Galaxy Watch
Correct
0 Likes
Terrapin69
Astronaut
Options
Galaxy Watch
Only on the watch
0 Likes
Samarama23
Astronaut
Options
Galaxy Watch

Just here to say I'm having the same issue.  My watch shows I have appointments today (sunday) when on my phone it shows I have nothing today and all those appointments are on Monday. Which is where they should be. I have tried other calendars, playing with settings. Nothing helps. I have resorted to closing the complication as "date" instead of "event" And it now shows me the next week and I can click it on my watch face to bring me to the correct information. Next best thing I guess... annoying though 

0 Likes