Original topic:

FIXED: Samsung health crashing moments after being launched (Galaxy Watch 5, Android 13)

(Topic created: 09-21-2022 10:15 PM)
Veerevere
Constellation
Options
Galaxy Watch

I'm writing this for anybody who's having a problem with Samsung health force closing itself after a few seconds of being open. If you have tried factory resetting your watch, uninstalling Samsung health, Galaxy wearable, the watch manager- and reinstalling all of them, and you still have this issue: continue reading. 

My health app stopped working just one day after purchasing my Galaxy Watch 5 and using it with my pixel 6. I noticed the health app wouldn't crash after I reinstalled it, but would start crashing the instant it synchronized data with my Samsung account. The data that was backed up got corrupted somewhere along the line, and it was breaking my app.

Doing the following allowed me to use Samsung health again. Please note that the steps you'll have to take may vary if you have a Samsung phone.

 

1. Forget your watch from your phone's bluetooth and uninstall Samsung health, Galaxy wearable, and watch manager apps from your phone. 

2. Factory reset your watch and wait for it to prompt you to set it up

3. You're going to want to set up your watch as a new watch without using the backup from your Samsung account. Even when the setup is done, you may be prompted to synchronize your account or restore from a backup in the wearable app. Skip this.

4. Do not set up the Health app yet. Instead, navigate to watch settings in the wearable app and disable "Auto Backup" under Samsung cloud.

5. Also under Samsung cloud, on the same screen as the previous step, will be the option to delete backups. Go here and delete all backups. 

6. Set up the Health app by signing into your account and following all of the steps. 

7. Open settings under the three dots on the top right of the health app and disable "Sync with Samsung account."

8. Use your watch like you normally would!

 

I have yet to discover if it's possible to continue backing up data after having this data corruption issue. To be honest, I'm a little scared to try it! But this fixed it for me. Your mileage may vary. Let me know if this helps someone.

 

 
0 Replies