cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Asteroid

Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I don't get why exactly but when i go from bluetooth to WiFi like when my phone is charging and I'm still wearing my watch, it usually will just notify me I'm in standalone mode and won't switch until i go into settings and tell it to connect to my wifi network.  My former Android Wear watch did this seemlessly without me noticing but this watch i often lose my notifications when I'm trying to top my phone off and I'm still wearing the watch around the house . Going in and out of bluetooth range basically makes the feature worthless. When it does automaticly switch it's usually after 10 minutes of being on standalone mode. So what gives?

1 SOLUTION

Accepted Solutions
Highlighted
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I have another work around. Seems issue occurs if you've ever selected "Sync wifi profiles". If you've turned it on at least once, disabling it does not seem to resolve the issue as per previous posts.

 

So this is what I did

1. Disabled Sync wifi profiles

2. Reset my watch - you may want to make a backup as you will lose everything

3. Clear storage of Galaxy wearable App on your phone

4. Go through the setup process again

5. Set wifi to Auto mode on your watch

6. Setup your WiFi connections on your watch. (You will have to turn off Bluetooth on your watch to be able to do this)

7. To test this, just connect your watch and phone via Bluetooth. 

8. Disconnect Bluetooth

9. Remote connection via WiFi will kick in providing watch and phone are on the same wifi, and will not require you to "Forget" wifi and re-enter credentials.

10. note: it takes about 1 min for remote connection via WiFi to kick in

11. Remember: NEVER ENABLE SYNC WIFI PROFILES (this must be a buggy setting)

 

*EDIT*

I have not restored my backup I made. I was worried that the restore would re-add my corrupt wifi profiles and the issue would persist. Maybe someone can test this?

View solution in original post

Reply
Loading...
90 REPLIES 90
Highlighted
Community Manager
Community Manager

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Hello @Cormaster, can you please provide me with the model number of your device?


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

Reply
Loading...
Highlighted
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

May Galaxy Watch is doing something similar. It works great so far with the exception that it won't connect to my wifi. It sees the wifi and lets me enter my password, but will not connect. I've tried it better than a dozen times. I've upgraded the software.  Any suggestions as to how to fix this? 

Reply
Loading...
Highlighted
Supernova

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

@userpJsOBLkKeC: Does your Wi-Fi password contain any special characters? 

Reply
Loading...
Highlighted
Asteroid

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

No

Reply
Loading...
Highlighted
Supernova

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

@Cormaster: Can I get the following information?

 

Model Number

Current Software Version

Reply
Loading...
Highlighted
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION
No, it's a short alphanumeric.
Reply
Loading...
Highlighted
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Mine wont connect either unless I'm actually using it. So if I turn off bluetooth or walk out of range it wont switch to wifi unless I start using an app that needs it. Understand why for battery saving but dumb as I would like to get calls or text messages if I put my phone in the house and run out to the mailbox real quick. 

Reply
Loading...
Highlighted
Galaxy

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

The watch doesn't support calls over wifi, but provided the wifi extends beyond the house you should at least get notifications for texts.

 

I've noticed that the switch over has become very erratic, disabling BT results in the watch immediately reporting it has connected to wifi successfully and yet the remote feature as you say takes an age to connect, I tried sending an SMS and i get 2"Connecting to phone remotely ..... if this takes to long, try again..." with an OK soft key to dismiss the message.

 

Yet another bug to file please Admins

Reply
Loading...
Highlighted
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION
It so sad that samsung is not willing to fix the ongoing issues. So pathetic!
Reply
Loading...