cancel
Showing results for 
Search instead for 
Did you mean: 
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Same problem.  I am a teacher and I leave my phone on my desk a lot.  I wanted to use my watch to still get notifications and emails when I am not near my phone.  When I walk to the office or anywhere my Bluetooth is lost and wifi does not connect until I turn Bluetooth off and then reconnect to wifi.

Reply
Loading...
Asteroid

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Is anyone from Samsung technical support gonna reply here? It seems like very comment issues here!! And I also find it kinda funny that no one ever mentions that on all of those YouTube reviews!? 

Reply
Loading...
Asteroid

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I have the same problem. My watch will not reconnect to my wifi. I can only connect to wifi if I forget the wifi network and re-enter my password every time! Useless...

Reply
Loading...
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I have another work around. Seems issue occurs if you've ever selected "Sync wifi profiles". If you've turned it on at least once, disabling it does not seem to resolve the issue as per previous posts.

 

So this is what I did

1. Disabled Sync wifi profiles

2. Reset my watch - you may want to make a backup as you will lose everything

3. Clear storage of Galaxy wearable App on your phone

4. Go through the setup process again

5. Set wifi to Auto mode on your watch

6. Setup your WiFi connections on your watch. (You will have to turn off Bluetooth on your watch to be able to do this)

7. To test this, just connect your watch and phone via Bluetooth. 

8. Disconnect Bluetooth

9. Remote connection via WiFi will kick in providing watch and phone are on the same wifi, and will not require you to "Forget" wifi and re-enter credentials.

10. note: it takes about 1 min for remote connection via WiFi to kick in

11. Remember: NEVER ENABLE SYNC WIFI PROFILES (this must be a buggy setting)

 

*EDIT*

I have not restored my backup I made. I was worried that the restore would re-add my corrupt wifi profiles and the issue would persist. Maybe someone can test this?

View solution in original post

Reply
Loading...
Asteroid

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION
Thanks!! I'll give it a try ASAP!!
Reply
Loading...
Asteroid

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I got it to work without resetting the watch:

 

1. Disable Sync wifi profiles -> in Wear app

2. Forget the wifi network that does not auto-connect -> on Watch

3. Re-enter wifi password -> on Watch 
    (You will have to turn off Bluetooth on your watch to be able to do this)

4. Set wifi to Auto mode -> on Watch

 

To test:

1. Turn on Bluetooth -> on Watch and -> Phone to connect the Watch to the Phone

2. Turn Bluetooth off -> on Phone (watch goes to stand alone mode)

3. Wait 1 minute and the watch will auto connect tot the wifi network

 

Worked all night (tried several times) for me.

Have to wait and see if it still works tomorrow ;-)

 

As user3l2f0l0IMP said: DON'T ENABLE SYNC WIFI PROFILES. 

 

 

 

 

Reply
Loading...
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

@userFe8vCcSh9w

Thank you for simplest solution, will test it today at home too.

I have the same issues as all you reporting here. I don't understand why Samsung doesn't allow all countries to discuss issues on the same forum. I'm from Russia and were able to find workaround only here on that forum.

The only reason I bought the Samsung Watch 42mm (still a little big for my small hand) - it has "woman" design and notification over wi-fi to leave my phone on desk and walk in moy house with watches only.

 

My list of connection related issues:

1) remote connection doesn't turn on automatically, for me reconeecting phone to wifi networked helped but still I was unable to get remote mode enabled automatically.

2) 5G wi-fi doesn't work

3) Wi-fi with authentication via web page doesn't work at all, watch sais not supported. The most of non-home wi-fi networks are setup that way. I can't use wi-fi at work for that reason at all.

Reply
Loading...
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Hi

 

How do I disable ' sync wifi profile' when I only have acccess to the iOS version of the Samsung watch app.

(I look like this functionality is not included in the iOS version)

Reply
Loading...
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

Same issue for me using iOS (iPhone).

 

My problem goes a step further in that my watch won’t connect to

wifi at all. I find my home network (same one phone connected to) and select. Type in the correct password and press connect. It just goes back to the previous screen as though I have pressed back and not connect.

 

any ideas?

Reply
Loading...
Constellation

Re: Galaxy watch won't automatically switch to WiFi all the time

JUMP TO SOLUTION

I have turned off wifi setting synchronization bw watch and phone. In overall I don't see changes in how remote connection works. It doesn' connect automatically when BT lost, when I try to force remote connection it works 10-20% of cases. When BT lost watches doesn't try to connect to wifi, I had to go to setting selct wifi... and only after that it is connected to wifi. Remote connection to watch usually doesn't appear after connection to wifi.

All these BT vs wifi connection is a magic, today during the night my watches got connected remotely even phone was near me with BT on. I tryid to force  BT connection but got message "update required". I had to go work and so didn't make any updates, when I came to work watches connected by BT without any actions from m y side. I will install these updates and monitor further.

Reply
Loading...