cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Today on the 6th of March I got my mobile operator's subscription on my galaxy watch active 2 set up (twin esim with normal sim). To my surprise, after a little automatic reboot of the phone and seeing the cellular network icon appearing at the top, things started to become weird. 

 

The phone became almost completely unresponsive and two manual reboots did not make it any better. What made it work again was for me to completely disable mobile data & dataroaming and do a manual reboot.

 

Before I activated it, everything ran perfectly smooth and no issue with lag or unresponsivenes of any sort with bluetooth & wifi + apps + custom watchface. Smiley Happy

 

I tried to make sure it was the cellular network and not something else:

 

etc. Info:

Watch:
Galaxy Watch Active 2, 44mm

Mobile network operator:

Telenor (Norway)

Subscription:

Telenor Yng 4GB with twin esim on the watch

Firmware:

Latest firmware. (According to phone, even after refreshing)

App updates:

All apps has been updated. (According to phone, even after refreshing)

 

When does it not lag:

turn off phone and then on again and enable just bluetooth. (No lag)
turn off phone and then on again and enable just Wi-fi. (No lag)
turn off phone and then on again and enable both bluetooth and Wi-fi. (No lag)

 

When does it lag:

- turn off phone and then on again and enable just mobile data. (lags)
- turn off phone and then on again and enable just dataroaming. (lags)

- Remove widgets  while mobile data & dataroaming is on. (lags)
- Close any open apps while while mobile data & dataroaming is on. (lags)

- Enable flightmode to turn of mobile data & dataroaming. (lags)
- Disable mobile data & dataroaming through Menu -> Connections - Mobilenetwork -> Always off. (lags)

- Changing to the standard watchface while mobile data & dataroaming is on. (lags)

 

What happens when it lags:

- Physical buttons can become unresponsive or VERY slow.
- Interface buttons can become unresponsive or VERY slow.
- Swiping left and right can become unrespsonsive or VERY slow.
- Double tapping or rotating the watchface towards me to turn on the screen can take a long while to make it open, or it doesn't make the screen turn on at all.

 

Temporarely solution:

- Only way to get rid of the lag is to turn off dataroaming & mobile data and then do a manual reboot of the watch.

---------------------------------------------------------------------------------------------------------------

 

I wonder if this is perhaps an issue with the software from the mobile network operator?

 

Is there a fix to this issue?

 

 

 

18 REPLIES 18
Highlighted
Astronaut

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Hi, 

Did you get a solution for this issue? I am experiencing the exact same issue once 4g is enabled. 
I am also with Telenor.

For me the issue goes away once the watch reconnects to the phone via BT. However, the whole point of a LTE enabled watch is to not always have to bring my phone. The slowness comes back instantly if i connect to LTE.

Reply
Loading...
Highlighted
Astronaut

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Exactly the same thing is happening with my active 2. I am also with Telenor, norway

Reply
Loading...
Highlighted
Asteroid

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Exact same problem with my Active watch 2 as well. I have Telenor Yng 4GB. Once reconnected to the phone via BT, the lag disappears. 

Considering to return mine if no fix can be found very soon. The watch is basically useless to me without the LTE feature.

This is very frustrating..

Reply
Loading...
Highlighted
Constellation

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Same exact here. Also Telenor

Reply
Loading...
Highlighted
Astronaut

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Same problems for my Samsung Galaxy Watch, also using Telenor. As you say, what´s the point with LTE if the watch cannot work as a stand-alone unit?? By the way, I´m using the watch with an iPhoneX, and I know that´s not a perfect match. But still the watch itself should be able to work "on it´s own"?

Reply
Loading...
Highlighted
Constellation

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Hi guys!

 

I also got this problem with Samsung Galaxy Watch 2, once disconnecting phone, just LTE on watch, it lags. Anybody found a solution or fix for this?

Reply
Loading...
Highlighted
Constellation

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Hi, i got my watch at 3.april and I have the same problem. I thought I was something wrong and contact Samsung support and they sent me a new watch 30 april. But I still have the same problem. Slow and not responding when connected to telenor network.

Reply
Loading...
Highlighted
Asteroid

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Did you get any information from Samsung about what the source of the problem might be? Is it an issue related to Samsung, or is it something that Telenor has to fix with their network? 

Reply
Loading...
Highlighted
Asteroid

Re: Samsung Galaxy Active 2 watch becomes slow/unresponsive when enabling data roaming

Hello! Is there any news on this problem, either from Telenor or Samsung?

 

I have the exact same problem, to the details of the exelent description from TMyr, and I am also a Telenor customer. The connection of eSim and my watch was smooth, and everything seems ok when disconnected from phone. The 4G, Telenor and connection indicator shows up in my watch to inform that the watch is connected to the mobile network in standalone mode. But then the watch gets slow to the point that it is useless.

 

I have contacted the support of Telenor where the problem is described, and also provided a link to this thread in the (optimistic) hope  that Telenor will take a deep dive into the problem.

 

I will share the reply here as soon as an answer is given from Telenor.

 

In the mean time, if anyone has some information, or even a solution, please post here. 

Reply
Loading...