Original topic:

Watch 4 - wifi bugs are RIDICULOUS

(Topic created: 07-25-2022 01:21 PM)
user54SZCm8wvo
Asteroid
Options
Galaxy Watch

I understand wifi uses a lot of battery so it's an "enhancement" that the Watch turns off my wifi on its arbitrary whim...

HOWEVER...when I need to use wifi, I want to use wifi. I don't want to fight with my Watch. I have had so many issues in the 2 weeks I've owned this Watch relating to wifi that I'm seriously thinking of dumping it for another watch brand!

  • I've factory reset it 3x.
  • I've updated all apps & software to the newest available.
  • I've restarted my phone and Watch hundreds of times.
  • I've reset my connections.
  • I've 'forgotten' my wireless network multiple times.
  • I've re-entered my difficult network password too many times to count.
  • I've used the Watch default wifi network settings and also custom Static IP settings.

 

Issue #1: connecting to my wifi network is at LEAST a 10 minute process. 

  • WiFi is on, but not connected to a network.
  • I click my SSID.
  • It attempts to connect to my network.
  • It fails, "wrong password"
  • I click it again to connect.
  • It fails, "wifi connection failure"
  • This goes on & on, the Watch failing to connect because it insists my password is either incorrect or there's a wifi connection failure.
  • Then after about 10 minutes, the Watch decides 'you know what? This SSID & password combo is actually fine - CONNECTED!' without me changing any password b/c it's CORRECT, or doing anything else.
  • If I accidentally hit that wifi toggle (turning it off), even if I immediately toggle it back on...I have to repeat the above process allllllll over again. Every time.

 

Issue #2: The Watch likes to change my SSID settings. All the devices on my network are assigned static IPs. The Watch default settings is to use a "randomized MAC address".

  • I click my SSID
  • Scroll down to Advanced
  • Scroll down to Randomized MAC
  • Toggle it off
  • Hit save
  • Connect
  • See Issue#1 above, re: Wrong Password Games for 10 mins
  • Finally connects
  • MAC address is randomized.
  • I disconnect
  • Repeat the first 8 bullet points above
  • When it finally connects, it is using the device MAC.

I've also changed the IP settings from DCHP to Static and filled in all the correct corresponding info, but as I said, the Watch changes my SSID settings to default whenever it feels like it. Inputting all that info every time I need to connect to wifi is a huge pain and has made no difference in performance.

 

Issue #3: I shouldn't have to turn everything else (bluetooth, mobile) off to force it to use wifi.

Example: trying to control my home Roku from the Watch. Watch and Roku need to be on the same network. Watch says it can't connect to the Roku b/c it "isn't on the same network" - but I'm trying! I've toggled my wifi on! It says it's connected!

Apparently the Watch will use any other data connection OVER wifi, unless wifi is literally the only option available. Once everything is off EXCEPT wifi, it is suddenly able to see the Roku, without me having to do anything else. Of course I now can't get my calls or texts b/c LTE is off, but at least I can use an app properly!

There are other apps I use that also require the same wireless network for the apps to work w/my phone or Watch. I have no problem doing any of this on my phone, but trying to get the Watch to work is an ordeal everytime. 

Not only that, but my LTE service sucks at home, and bluetooth is slow. I have 1 Gig wifi. Installing apps that are only like 30MB takes a couple of mins vs seconds it would over wifi!

7 Replies
Jaybklyn
Astronaut
Options
Galaxy Watch
My question can I open my car with my smarth watch s3 yes or no
0 Likes
Jetster
Comet
Options
Galaxy Watch
Hello, I fear this may be a software issue. Have you purchased your watch through a 3rd party service?
0 Likes
Jetster
Comet
Options
Galaxy Watch
I have used a Galaxy Watch Active 2 for a few years and I have never had an issue, however it only takes a few seconds to connect to wifi. I've noticed your steps to fix this issue, I would've done the same.
0 Likes
Jetster
Comet
Options
Galaxy Watch
I do not work with and I am not associated with samsung in any way. I would consider talking to a professional that works with Samsung for proper assistance.
0 Likes
user54SZCm8wvo
Asteroid
Options
Galaxy Watch

No. I bought it directly from the Samsung store - brand new. 

It's not rooted or modded, so the credit for the glitchy software goes directly to Samsung.

0 Likes
Jetster
Comet
Options
Galaxy Watch
Sorry for any inconvenience this may cause.
0 Likes
user54SZCm8wvo
Asteroid
Options
Galaxy Watch

Issue #1: connecting to my wifi network is at LEAST a 10 minute process. 

  • WiFi is on, but not connected to a network.
  • I click my SSID.
  • It attempts to connect to my network.
  • It fails, "wrong password"
  • I click it again to connect.
  • It fails, "wifi connection failure"
  • This goes on & on, the Watch failing to connect because it insists my password is either incorrect or there's a wifi connection failure.
  • Then after about 10 minutes, the Watch decides 'you know what? This SSID & password combo is actually fine - CONNECTED!' without me changing any password b/c it's CORRECT, or doing anything else.
  • If I accidentally hit that wifi toggle (turning it off), even if I immediately toggle it back on...I have to repeat the above process allllllll over again. Every time.

Issue #2: The Watch likes to change my SSID settings. All the devices on my network are assigned static IPs. The Watch default settings is to use a "randomized MAC address".

  • I click my SSID
  • Scroll down to Advanced
  • Scroll down to Randomized MAC
  • Toggle it off
  • Hit save
  • Connect
  • See Issue#1 above, re: Wrong Password Games for 10 mins
  • Finally connects
  • MAC address is randomized.
  • I disconnect
  • Repeat the first 8 bullet points above
  • When it finally connects, it is using the device MAC.

I've also changed the IP settings from DCHP to Static and filled in all the correct corresponding info, but as I said, the Watch changes my SSID settings to default whenever it feels like it. Inputting all that info every time I need to connect to wifi is a huge pain and has made no difference in performance.

I *may* have found the solution for Issue #1 (thereby fixing Issue #2).
I believe the Watch 4 is the first Galaxy Watch that supports both 2.4ghz & 5ghz wifi connections? 
Well it appears to have no trouble connecting to any 2.4ghz channel/frequency, 5ghz is another story. 

I have a tri-band Wifi6 router: 2.4ghz, 5ghz (1), 5ghz (2) all using the same SSID as a 'smart connect' feature my router has. 5ghz (1) uses channels 36-64; 5ghz(2) channels 100-165.

I enabled Developer Settings in my Watch 4 settings, enabled Wi-fi Verbose Logging, then watched back in Settings > Connections >  Wi-Fi what happened when it tried connecting via wifi. 

With wifi debugging on, the connected wifi network displays additional info. Example:
MyWifiNetworkSSIDName
Connected f=2437
router:MAC:address static

Which displays the network I'm connected to, what frequency, the router info, & DHCP/ip info.  Frequencies in the 2400s = 2.4ghz; 5000s = 5ghz. 

I noticed that I connected immediately to 2.4ghz frequencies, but it was hit or miss with the 5ghz frequencies.

Upon closer inspection, it appears the Watch only supports the lower frequency 5ghz channel widths, aka 5ghz (band 1); channels up to 64.
When it tries to connect to 5ghz (band 2) is when it continually disconnects, throwing "incorrect password" and "wifi connection failure" errors. 

With Smart Connect, most wifi-enabled devices connect to the band they support. I've got a kid using a tablet (2.4ghz only) and my Galaxy S21 Ultra (5ghz wifi 6) all connected to the same Smart Connect wifi network.

This Watch is the only device I've come across that has trouble connecting. My guess is it either A.) doesn't think it should have a problem connecting to 5ghz band 2, so it keeps trying to connect, or B.) doesn't have the capability to distinguish a difference between 3 wifi bands sharing the same SSID, so it just tries to connect to first band available.

Anyways, what I did to fix this was go into my router wifi settings and set up MAC filtering. I set it to block the Watch (actual, non-randomized) MAC address from connecting to 5ghz band 2. This forces the Watch to either use my network's 2.4ghz band or 5ghz band 1 only. Since then I haven't had problems connecting.

 

Now I just need to figure out how to force the Watch to use my wifi for data transfer without having to turn off bluetooth and LTE.

0 Likes