cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Fit will not update, just an exclamation point

I just recently got a Galaxy Fit (SM-R370NZKAXAR). It was one sale. I charged it, downloaded the wearables app, and paired it. There was a notice about to update the band software. I downloaded it and attempted to install it. The installation failed and the app said to try again later; while the Fit simply had an exclamation point (!) on the screen and would do nothing. 

 

I have tried updating the software more than a dozen times, with the same result. Sometimes the progress "clock" gets to around 20%, sometimes 80%. The highest was over 90%.

 

I have reset the Fit several times and re-paired it; but, it has made no difference.

 

I have uninstalled the wearable app from my phone and re-installed it; but, it has made no difference.

 

Now, I cannot even use it without the update, as after a reset, once it's paired with my phone, I get the exclamation point.

 

Any ideas, ohter than using it as a light-weight paperweight?

Thanks.

 

 

2 REPLIES 2
Highlighted
Cosmic Ray

Re: Fit will not update, just an exclamation point

Back up, unpair, turn off charge full then turn on repair with phone restore and try updating then. Try to have full charge and good Wi-Fi signal.
Reply
Loading...
Highlighted
Constellation

Re: Fit will not update, just an exclamation point

Thanks. I did hte following:

Full charge on Fit, phone charged & plugged in.
Unpaired the Fit and reset it.
Turned the Fit off.
Wait.
Turn Fit on ("52E1" displayed).
Paired the Fit & phone.
Upon finishing pairing, the Fit displayed the exclamation point (!).
Selected update band software --> install --> install now.
Software began installing, progress displayed on Fit.
Sometime after 60% it stopped and went back to the exclamation point (!).
App says, "Couldn't update software. Try again later."

 

I guess I wish the Fit was heavier, as then it would be a decent paperweight.

Reply
Loading...