cancel
Showing results for 
Search instead for 
Did you mean: 
Astronaut

Samsung Gear S3 Frontier Issue

Hi there,

 I'm having issues trying to connect my Samsung Gear S3 Frontier to my Galaxy S10+. It used to do it without any issues up until over a week ago, it just wouldn't connect anymore. Both of the Bluetooth settings are on, I've tried resetting my watch, tried uninstalling and reinstalling Samsung Wearable, and tried turning off and turning on both of them, but now it's not even showing up in the Bluetooth menu anymore. I've talked with 4 different Samsung assistants over this, literally tried every possible troubleshooting method they offered, but still had no luck. After doing a lot of testing and research, I think I have a solution. Before Samsung started using Samsung Galaxy Wearable, I remember we were using Samsung Gear Manager previously. My only guess is when they switched it over, it might've removed older models from the app. If that is the issue, hopefully there can fix to the bug or add both Wearable and Gear Manager to the Samsung app list. If anyone with the technical knowledge could respond and maybe look into this, I would greatly appreciate it. Thank you.