Showing results for 
Search instead for 
Did you mean: 

Sensors s3 stopped working.

The sensors of my Samsung gear s3 Classic stopped working ( I think after an update). 
Nothing works now, the heart rate, the step counter , the altitude meter, ... nothing where you need a sensor.

the rest works perfectly.  
in the afternoon I changed the watch face and suddenly it messy red my heeft beat ONE TIME!!!
now it stopped working again. 
How can this problem can be solved?



Re: Sensors s3 stopped working.



Hope you are doing well, my friend!

Sorry to hear about this watch issue. 

Have you tried a reset of the watch to see if that helps? 


Performing a factory data reset removes all data from the device. Only perform a reset if absolutely necessary.


  • An alternate reset method is available if the device can be powered on and is responsive.
  • Read these instructions in their entirety before attempting.


  1. Ensure your watch is powered off.
  2. Press and hold the Power/Home button (located on the right-edge) until 'Rebooting' appears at the bottom of the screen then release.
  3. Press the Power/Home button repeatedly until the 'Select REBOOT MODE' screen appers.
  4. Select Recovery.
    Note Press the Power button to cycle through options
  5. When 'Recovery' is highlighted as seen in the image above, press and hold the Power/Home button until the device reboots again.
    Note Allow several minutes for the reboot process to complete.
    Note If applicable, set up your device.


Please click " ✓ Accept as Solution" if this reply solved your issue or pointed you in the right direction. Click the heart to let me know your appreciation! 

Notification emails do not accept replies. Login to the community to respond to this thread.

Re: Sensors s3 stopped working.

Hi John,

I also tried a reset and nothing seems to help. I think I've done almost everything and nothing seems to start the sensors. 
I keep on searching...

thx for your support and advice anyway. 
best regards.