Original topic:

MU6070 - unable to agree to terms and policy setup

(Topic created: 09-04-2021 09:34 PM)
userQXNmSkRZ3G
Astronaut
Options
HD and UHD TVs

I have an MU6070 58" and I'm unable to complete the terms and policy setup. I've tried numerous resets, firmware updates (usb too), and using the SmartThings app to register the device. Of note, it fails the smart hub connection test with an ERR30001 error although it reports a good internet connection. I've found countless ways this problem has been solved but none of them have worked for me and I can't help but feel that most of the time the solution is "I did a bunch of things and then it worked."

Is there a method to resolving this problem?

1 Reply
BethL
Cosmic Ray
Options
HD and UHD TVs
I have the same TV and have experienced similar issues. I don't know how to fix this issue. Trying to be helpful to you I've described below what things haven't worked for me. Remember it's not you, it's the MU6070.

My Smartthings (hub-only not wifi) went out 9 months after I bought it, and I've never replaced it. I have fiber and use the 2-in-1 router/gateway from my ISP. I experienced your same terms and conditions error message. If I remember correctly we used the app on my phone and Smartthings scanned for new products to register using wifi. Think barcode was also an option, but for me wifi scan worked only this one time. I was able to then use Smart View operate the TV. Some options are still Greyed-out. The TV remote in the Smartthings app is handy.
Smartthings companion apps compatible with a TV have never worked with this TV. I am able to use Samsung Dex mode just fine - my Phone wirelessly connects to the TV in Dex mode after toggling ON "scan for certified-wireless displays" option for my phone. It's turned off by default. Smart View works and I can use phone screen mirroring both to TV and from this TV.

The reliability of our MU6070 wifi was always rocky so it has an ethernet connection to my wifi extender. Wifi connects but won't stay connected. Config breaks each time anyone turns-off the TV regardless of whether eco settings are on or off. When the TV comes on again, it can't restablish wifi on the saved network. Only option that fixes - Reset found under General>Network>Network Settings. Grew sick of reentering SSID and password each time we wanted to watch tv and added an ethernet cable. I have TV IPV6 switched off and IP Remote on. Even with a wired connection the TV refuses to stay signed into my Samsung Account. My Samsung Account is the only one we use and shows up in the list of accounts previously signed in but I can't click it from the list. If I do, I get an error message. I sign in only to use Smartthings remote app or to check for updates to streaming apps. The less you try to integrate this TV across services, the better it works. That means linking Google is out. Google Home adds this TV as a light switch not a TV so it functions like one. Smartthings does not interact well with this MU6070 either. (Considered too old.) Linked with Google Home, the TV experienced more issues than before. Smartthings treats this TV more like a personal device and instead of working like it should as a TV, it works like a paired accessory for using with your phone. I assume to limit our access to the newest features. People choose to buy new products when old ones aren't capable of supporting new features. This one is totally capable of supporting updates, but Samsung stops releasing ware for TVs manufactured before 2018-2019. Not as sustainable as they claim in this area. In my experience registering the TV with my Samsung Account only allowed me to download TV apps. It never caused Samsung Members to offer me additional benefits or services.


TV software version: T-KTMAKUC-1290.3 submicom version: KTMMINTV-1010
0 Likes