Original topic:

Audio lag and distortion on T450 Soundbar when connecting to MacOS via Bluetooth

(Topic created: 04-19-2021 07:28 AM)
jjllee
Asteroid
Options
Home Theater

When I try to connect my Macbook Air running Catalina via Bluetooth to T450 Soundbar, there is significant audio delay and distortion (pitched down and slower, and then will skip). This only seems to happen when pairing the soundbar with MacOS. My iPhone pairs without issue to the soundbar, and my laptop pairs without issue to other Bluetooth audio devices. I also tried pairing another MacOS running Big Sur, and the same audio issues apply.

Does anybody else have this problem? Are there any reasons and/or fixes to this?

5 Replies
userbvMJhvYpot
Constellation
Options
Home Theater

I'm having the exact same issue. Have you found a solution yet?

0 Likes
jjllee
Asteroid
Options
Home Theater

Unfortunately no. I tried updating the firmware on the soundbar, enabling AptX audio codec on my comp, resetting PRAM, resetting all Bluetooth settings, and talking to Samsung customer service. Nothing worked.

Ended up selling it, and replacing it with a Vizio soundbar which has had no issues ๐Ÿคท๐Ÿปโ€:female_sign:

0 Likes
userg9DIcdKgJT
Constellation
Options
Home Theater

I experienced the same issue and it's really annoying. I am planning to sell my samsung soundbar and buy Vizio too. What Vizio model version did you get? 

0 Likes
jjllee
Asteroid
Options
Home Theater

I went for the Vizio V-Series 2.1 soundbar

0 Likes
userNzfVoek9Wg
Astronaut
Options
Home Theater

Yep going to do this aswelll! Samsung soundbar T420 <hidden>

 

0 Likes