JUMP TO SOLUTION Solved

Original topic:

Can't connect to Wifi HW-MS650 Soundbar

(Topic created: 05-09-2017 05:12 PM)
useruRi6OWvT3m
Constellation
Options
Home Theater

Hi, So I got the new MS650 Soundbar, but I've been trying to connected to Wifi for 3 days now with no luck.

So the only way to connect it is using the Samsung Multiroom app, but it just doesn't work.

The app finds my bar, but it tries to connect than just get an error message "" Ubable to connect your speaker to the network"

I tried using my Android phone, and I tried using an Ipad with no luck, I also tried connecting over 2.4 and 5ghz network.

I rebooted my modem, played around with wireless settings and nothing.

I feel like half the features of the soundbar are non usable and also wont be able to get firmware uptades.

I tried calling customer support but they weren't any help.

Any idea what could be wrong?

it's out of stock in most places, so my only option is returning it unless I can figure this out.

Any help is appreciated.

 

Here's the Soundbar I got: http://www.samsung.com/us/televisions-home-theater/home-theater/sound-bars/sound--premium-soundbar-h...

1 Solution


Accepted Solutions
Solution
user9Rz9YoOYdj
Asteroid
Options
Home Theater

Hi,

 

I just found a solution that worked for me.

 

I unplugged the power cable from the soundbar. Waited a couple of seconds, then plugged it back in.

Immediately after that, i pressed the add speaker btn and entered the password for the wifi in the app. 

 

The soundbar connected after 5 seconds. 

 

Hopefully this will also work for you.

View solution in context

49 Replies
user9Rz9YoOYdj
Asteroid
Options
Home Theater

Hi,

 

I got the same unit today, and I am also having issues connecting it to my wifi.

 

I press the add speaker button, the app sees the speaker, I give my wifi and password. Then after 1 min I get the same error as you.

 

Did you fix the issue, or does anyone know the solution?

0 Likes
user2XnDmJfQSk
Asteroid
Options
Home Theater

Hi,

You must turn on your location services on your mobile or tablet before starting to use Samsung Multiroom app for the first time.

Solution
user9Rz9YoOYdj
Asteroid
Options
Home Theater

Hi,

 

I just found a solution that worked for me.

 

I unplugged the power cable from the soundbar. Waited a couple of seconds, then plugged it back in.

Immediately after that, i pressed the add speaker btn and entered the password for the wifi in the app. 

 

The soundbar connected after 5 seconds. 

 

Hopefully this will also work for you.

View solution in context

useruRi6OWvT3m
Constellation
Options
Home Theater

Your are a saint! I follwed your instruction and finally it detected.

I was at this for 4 days now, and it was stressting me out.

Thank you so much my man!

0 Likes
user9Rz9YoOYdj
Asteroid
Options
Home Theater

Glad it worked out for you.

 

It really is a nice piece of hardware, i was also stressing at some point.

 

Grtz

0 Likes
usergbs0IOlpm9
Constellation
Options
Home Theater

I'm having the exact same problem. Could you provide a bit more details on the solution?

 

I tried unplugging the soundbar, plugging it in and powering it on, going to wifi mode, and using the multiroom app to new setup & add speaker, still hangs on the connecting to wifi.

 

Any other tips?

0 Likes
userN4hovNQxu9
Astronaut
Options
Home Theater

Thanks. Have been trying for a long time and this helped

0 Likes
uservfSmtCnol5
Astronaut
Options
Home Theater

The same issue has now affected me, all was well until I set up the surround speakers, now no WiFi message.

Tried everything to no avail - so annoying, funny wecarecall now getting this.

Samsung take notice please and sort out a solution, or mine will be going back shortly.

Any other ideas will be used from those joining this thread.

0 Likes
userXZqmUTuter
Constellation
Options
Home Theater

Hello Astronaut: I just followed Asteroid’s suggestion and it worked perfectly well for me. Now I have my Soundbar connected again to my Ipad, via Bluetooth. Best greetings from Charlotte, North Carolina...!

0 Likes