Original topic:

HW-Q950T WiFi does not work with WPA-3

(Topic created on: 3/7/21 8:13 AM)
Hoki03
Asteroid
Options
Home Theater

I purchased a Samsung HW-Q950T Soundbar system a couple months ago, and did not experience any issues connecting the system to my WiFi, which is a Google Nest WiFi mesh system configured with WPA-3 security.    

A few days ago my Soundbar stopped working on WiFi.... and showed as "offline" in SmartThings app.  I could not get it to re-connect even with a full Soundbar power cycle and WiFi router reboot.   I removed the device from SmartThings and tried to re-add it.  Only to discover that it would no longer let me add my WiFi credentials in the SmartThings app after the initial discovery of device.  My WiFi network shows without the "lock" icon on the WiFi SSID, and I cannot click in the password field.

The only thing that worked for me, was to turn WPA-3 OFF on my WiFi and then the SmartThings app allowed me to enter the WiFi password.   I was able to replicate this behavior multiple times.

Does the Q950T not support WPA-3 WiFi security?  or did something change in SmartThings?   It was working OK on WPA-3 the last couple of months... so obviously something changed recently.

1 Reply
Hoki03
Asteroid
Options
Home Theater

Posting a potential workaround I've discovered... until Samsung/SmartThings can fix it natively.

 

1) Disable/Unregister Alexa from the Soundbar settings in SmartThings.  Remove the device from Alexa App too else you may get a duplicate Device entry when you add it back again

2) Delete the Q950T Soundbar device from your SmartThings App

3) Enable WPA3 on your WiFi router and let router + any mesh satellites fully start up.  Verify internet connectivity etc.

4) Go back to SmartThings App and 'Scan for new devices'

5) When it finds your Soundbar, go through the normal steps to add it 

6) When it gets to the WiFi network stage, it will not let you enter the WiFi password... this is the issue seemingly unique to networks enabled with WPA3

7) Instead, Click on the WiFi network name and in the top right of screen use the "Add" feature

8) Manually enter your WiFi network name, and choose "WPA2_PSK",  encryption = AES  (depending on your router version/model you may have to try TKIP or some combo, but AES is typically the standard)

9) Enter the WiFi password and proceed with the setup...

Once I did this, my Soundbar displayed a "WiFi Connected" message and I can now control it using SmartThings.   Since the Q950T also includes Alexa, I enabled it in my settings and Alexa is responding to voice commands, which additionally seems to confirm WiFi connectivity is OK.    

I will test this out further, but it seems to me that my workaround is forcing the Soundbar to connect to WiFi on WPA2 security level since the routers are backward compatible even if you have WPA3 enabled.

@SamsungLou Samsung/SmartThings still needs to enable/fix WPA3 support natively via a firmware and/or SmartThings app update... but I'm glad I can now have WPA3 re-enabled on my WiFi.  I spoke with SmartThings and Samsung support yesterday and both agents have escalated my ticket to the engineers, but i'm told it could be 10 - 12 business days before I get any response.

 

Hope this bandaid fix work for others until we get a permanent fix from Samsung.

0 Likes