Original topic:

Samsung HW-K950 soundbar not working

(Topic created: 02-08-2023 10:26 AM)
Logan77
Constellation
Options
Home Theater

I purchased the Samsung HW-K950 soundbar in November 2016 along with 3 Samsung UN65KS8000 TVs. The soundbar worked close to 2 years then it stopped working. I tried to reset it and tried to reconnect the woofer and rear speakers multiple times but nothing worked and I gave up. Now I am getting close to my retirement, and I am hoping that I can make this soundbar work again and enjoy it during my retirement. I would appreciate any help and suggestions.

Current status of the soundbar:

      The main unit, the subwoofer and the surround speakers all power up.

      When I plug the subwoofer and surround speakers, I get the blinking bleu LED lights on all 3.

      When I power up the main unit using the On/Off button on the main unit or the remote, the unit first displays “HELLO” next “D.IN”. But most of the buttons on the remote and main unit do not work.

 

Below are the results of pressing the buttons on the main unit and the remote:

Main unit buttons:

     On/Off: It works as expected. Powers on and off the unit.

     Source: It just brings the “D.IN” on the display but it does not switch the source.

     Volume+: It just brings “VOL 30” on the display. In 2 seconds, the display changes to “D.IN”. Pressing this button again and again does not change the display.

     Volume-: Same as Volume+.

 

Remote buttons:

     On/Off: It works as expected powers on and of the unit.

     Source: It just brings the “D.IN” on the display but it does not switch the source.

     Sound: It just brings the “D.IN” on the display. Pressing this button again and again does not change the display.

     Effect: First the “D.IN” is displayed and pressing this button again the current effect mode is displayed. Pressing this button changes the mode (Standard, Music, Clear Voice, Sports, Movie, Night).

     Sound Control: It just brings the “D.IN” on the display but it does not work (pressing this button again and again produces no change).

     Level: It just brings the “D.IN” on the display but it does not work (pressing this button again and again produces no change).

     Volume: Pushing this button up or down, pressing it straight down changes nothing. Nothing is displayed.

     Woofer: Pushing this button up or down displays “SW +6” but in about 5 seconds the display changes to “D.IN”. Pushing this button up or down changes nothing. Pressing this button straight down displays “D.IN”.

     Play/Pause: Just displays “D.IN”.

     Up/Down/Left/Right: All 4 just display “D.IN”.

 

Steps I tried to reset the unit:

     I tried to reset the unit to factory setting by pressing and holding the Volume+ and Volume- buttons on the main unit for 10, 15, 30, 60+ seconds (multiple trials) while the unit was on and while the unit was off. This produced nothing. There was no change on the main unit or the display, indicating that the unit was reset.

     I tried to reset the unit to factory setting by pressing and holding the Play/Pause button on the remote unit for 10, 15, 30, 60+ seconds (multiple trials) while the unit was on and while the unit was off. This also produced nothing. There was no change on the main unit or the display, indicating that the unit was reset.

     I followed the instructions that I saw on Samsung Community (dated May 23, 2020) related to syncing the subwoofer and the surround speakers. This also did not help (my issue is beyond syncing the subwoofer and surround speakers). But I noted that while the unit is OFF and I press and hold the volume button on the remote straight down for 5, 6 seconds brings the “ID SET” on the display. Also pressing and holding the volume button longer than 6 seconds first brings the “ID SET” on the display and in about 10 seconds “WIRELESS SPEAKER RESET”. But the woofer and the surround speakers will not sync (blue LED lights will continue blinking).

     I tried pressing the “WI-FI SETUP” and “SPK ADD” buttons on the bottom of the main unit to see if it would change anything. But nothing changed.

     I tried all the above steps while the unit was connected to my Samsung TV (HDMI-ARC) and while connected to a DVD/CD player via digital input and AUX input. I tried with all 3 Samsung TVs. I also tried with nothing connected to the unit. It made no difference. There was no sound even on the main unit speakers.

     February 7, 2023, I downloaded the latest firmware from Samsung website (SAT-HAK16WWC). I unzipped and copied the contents to a USB drive root. I connected the USB drive to the micro-USB port using an adapter. I followed the instructions on Samsung website and while the USB drive was connected to the unit and I turned it on. I tried multiple times, but nothing happened. I also copied the “upgrade.msd” file to the root and tried again with no change. I even tested the USB drive connecting to my PC using the micro-USB adapter and I was able to read/write to the USB drive. The firmware update trials also did not work.

At this point I ran out of ideas. But on the positive side the unit powers on. I am posting this to the Samsung Community site hoping that somebody will be able to help. I used this soundbar very little and when it worked it sounded very well.

Thanks in advance.

3 Replies
Reg2
Constellation
Options
Home Theater

Similar situation to you - worked for 2 years and now the tv won’t see it and the reset button combinations don’t seem to do anything. My remote functions seem to be working ok unlike yours but the (Samsung series 7) tv now refuses to see the soundbar in the select Speaker menu - weirdly it did ealrlier today despite not outputting sound but now doesn’t even show it. 
Perhaps there’s been an auto update in the tv that’s broken it?

I’ll keep trying and let you know if I get anywhere!

 

 
0 Likes
Reg2
Constellation
Options
Home Theater

I just managed to factory reset mine and it’s working again now - I had to turn it off using the switches on the side then turn it on and immediately press the vol up and down buttons together until it displayed ‘init’. I let go and it switched off, switching on again and the tv asked if I wanted to connect to it. Hope that works for you!

 

 
0 Likes
Logan77
Constellation
Options
Home Theater

Thanks for your reply. I tried the same steps, but it did not work. Using the buttons on the right side of the main unit, I turned it off and on and immediately I pressed the vol up and down buttons together. The display never changed to "INIT" and it just displayed "D.IN" for a few seconds and went dark. I tried this multiple times with no success. I tried this while the soundbar was connected via HDMI/ARC and I could see that the TV was recognizing that the soundbar was connected. As far as I can see the soundbar cannot complete the boot steps and it gets stock. It cannot even respond to my factory reset request. I wonder if I am the only unlucky one having this issue.

Thanks again.

 

 

 
0 Likes